Bug 171867 - "Open" should pass multiple files to the same handler
"Open" should pass multiple files to the same handler
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nautilus (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 05:24 EDT by Toralf
Modified: 2015-01-07 19:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 04:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2005-10-27 05:24:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050226 Firefox/1.0.1

Description of problem:
When multiple files are selected, "Open" from the "File" or the "right-click" will execute a handler ("action") application once for every file selected, passing exactly one file argument every time. It seems to me that it should instead execute a handler only once, specifying all relevant files in one go, if several files have the same handler - provided that "can_handle_multiple_files" is true for the application in question.

Specifically, I want this for RPM package files. If I select multiple rpms, it is usually because they are related rpms with inter-dependencies, and these are best installed together. Separate installation essentially works only if the operations are started in one specific order according to the dependencies, which makes the whole task a lot harder. Also, the dependencies might conceivably be structured in such a way that installation one package at a time just won't work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert one of the Enterprise Linux install CDs
2. Open a directory view for the CD if necessary.
3. Go to directory RedHat/RPMS in the directory view for the CD.
4. Select two files
5. Select "Open"

  

Actual Results:  Two system-install-packages windows are opened - one for each of the two packages.

Expected Results:  One system-install-packages window is opened, allowing simulataneous installation of both packages (if they aren't already installed.)

Additional info:

Note that in the "browser" mode, Nautilus will also present an option "Open in 2 new windows". Currently, this makes no sense, since plain "Open" will also open in 2 new windows.

And, yes, I do know that the package manger can automatically pick up the required package when a genuine install CD is used, but that's not the point.
Comment 1 Alexander Larsson 2005-10-28 04:42:41 EDT
This is a known issue upstream, filed as:
http://bugzilla.gnome.org/show_bug.cgi?id=105653

Closing this UPSTREAM, as all development like this happens upstream.

Note You need to log in before you can comment on or make changes to this bug.