Bug 171870 - kdelibs and kde-i18n-Polish conflict during "yum update"
kdelibs and kde-i18n-Polish conflict during "yum update"
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 171958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 06:14 EDT by Robert P. J. Day
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2005-10-27 06:14:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
  Trying to do a "yum update" on a fresh install of FC4 generates:

Transaction Check Error:   file /usr/share/doc/HTML/en/common/1.png conflicts between attempted installs of kdelibs-3.4.2-0.fc4.1 and kde-i18n-Polish-3.4.2-0.fc4.1
  file /usr/share/doc/HTML/en/common/10.png conflicts between attempted installs of kdelibs-3.4.2-0.fc4.1 and kde-i18n-Polish-3.4.2-0.fc4.1
  file /usr/share/doc/HTML/en/common/2.png conflicts between attempted installsof kdelibs-3.4.2-0.fc4.1 and kde-i18n-Polish-3.4.2-0.fc4.1


Version-Release number of selected component (if applicable):
kdelibs-3.4.2-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1. Fresh install of FC4.
2. "yum update"
3.
  

Additional info:
Comment 1 Ngo Than 2005-11-03 10:17:24 EST
i have taken a look in the specfile and did not find something which could 
cause this problem. Could you please try to update the kde packages 
with rpm (rpm -Fvh kde*) instead yum. Does this problem still appear? 
 
Many Thanks for your report. 
Comment 2 Ngo Than 2005-11-03 11:35:38 EST
*** Bug 171958 has been marked as a duplicate of this bug. ***
Comment 3 Ngo Than 2005-11-03 11:41:08 EST
i have done a fresh fc4 installation on my test machine. 
First, i have tried to update KDE packages which rpm command and it works 
without any problem. With yum it breaks with above errors. 
It seems a bug in yum. 
 
Comment 4 Seth Vidal 2005-11-03 11:44:10 EST
can you please send the out put of this command:

yum list installed


thanks
Comment 5 Robert P. J. Day 2005-11-03 11:47:08 EST
I've only ever seen this error immediately after a fresh install of FC4,
followed by a "yum update".  (Actually, you have to first delete a few
kernel-related packages to get past a transaction error, but this error has
happened *every* time for me in those circumstances.)
Comment 6 Dimitri Papadopoulos 2005-11-04 02:11:25 EST
I guess you need the output of 'yum list installed' before 'yum update'?

I worked around the problem by removing package kde-i18n-Polish before running
'yum update'. I can't reinstall the workstation anymore (it's being tested) so I
can't provide this output now. But really, to reproduce the bug you just need a
complete FC4 installation.

By the way, I also had to remove packages cman-kernel, dlm-kernel, GFS-kernel,
and gnbd-kernel to be able to upgrade. They seem to be tied to a specific
version of the kernel, but updates are not provided alongside kernel packages.
For example, current updates are:
	kernel-2.6.13-1.1532_FC4
	cman-kernel-2.6.11.5-20050601.152643.FC4.15
	dlm-kernel-2.6.11.5-20050601.152643.FC4.15
	GFS-kernel-2.6.11.8-20050601.152643.FC4.18
	gnbd-kernel-2.6.11.2-20050420.133124.FC4.51
Comment 7 Robert P. J. Day 2005-11-04 04:17:21 EST
Here's the entire sequence of what happens when you do an "Everything" FC4
install and try to "yum update" in one operation these days -- this is from just
a few days ago.  The install works fine, but the first attempt at "yum update"
complains about a conflict based on the four *-kernel packages listed above
because they aren't compatible with the current kernel.

You can either just remove those packages (most people don't need them anyway),
or try again with:

  # yum --exclude="*-kernel" update

That command is the one that complains about the clash between kdelibs and
kde-i18n-Polish.  To get around that, I just removed the "kde-i18n-Polish"
package and then the above yum update command started to work.

Finally, if you don't have enough free space in /usr, the yum command will
eventually fail given that, these days, doing a yum update on a *fresh* install
involves updating over 550 packages.  To get around that last issue (obviously
not really an error, just an annoyance), I did the update in two steps:

  # yum --exclude "*-kernel" update "kde*"
  # yum --exclude "*-kernel" update

and everything was happy.
Comment 8 Seth Vidal 2005-11-06 23:52:25 EST
comment #6: Yes - I need to see what was going on beforehand.
Comment 9 Jeremy Katz 2006-04-19 16:20:01 EDT
Closing due to inactivity.  Please reopen if you can add further information to
the report.

Note You need to log in before you can comment on or make changes to this bug.