Bug 171877 - rpmbuild --sign does not ask for pin or uses gpg-agent
rpmbuild --sign does not ask for pin or uses gpg-agent
Status: CLOSED DUPLICATE of bug 128771
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 08:28 EDT by Ralf Spenneberg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 17:39:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Spenneberg 2005-10-27 08:28:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
I use a smartcard for storing my gpg-keys. 
When signing something I need to enter a pin instead of a passphrase.

rpmbuild --sign just asks for the passphrase. This clearly fails. It never asks for the pin. 

Therefore I tried to use gpg-agent but rpmbuild does not honor gpg-agent. Even when using:
%_gpgbin "/usr/bin/gpg --use-agent"




Version-Release number of selected component (if applicable):
rpm-build-4.4.1-22

How reproducible:
Always

Steps to Reproduce:
1. use gpg-keys stored on smartcard protected by pin
2. rpmbuild -ba --sign <package>
3. Asked for passphrase would expect pin or agent
  

Actual Results:  Asked for passphrase

Expected Results:  Asked for pin or start pinentry program

Additional info:
Comment 1 Paul Nasrat 2005-11-28 17:39:49 EST

*** This bug has been marked as a duplicate of 128771 ***

Note You need to log in before you can comment on or make changes to this bug.