Bug 171882 - yum fails with "parser error : Start tag expected, '<' not found"
yum fails with "parser error : Start tag expected, '<' not found"
Status: CLOSED DUPLICATE of bug 171881
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 09:30 EDT by Stanton Finley
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 10:45:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanton Finley 2005-10-27 09:30:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
yum update fails more often than not with third party repositories with errors such as:

//var/cache/yum/dag/repomd.xml:1: parser error : Document is empty

^
//var/cache/yum/dag/repomd.xml:1: parser error : Start tag expected, '<' not found

^
Cannot open/read repomd.xml file for repository: dag

Doing a "yum clean all" sometimes helps as does doing a "yum clean all" followed by clearing the upstream cache by doing something similar to:

wget --cache=off http://apt.sw.be/fedora/4/en/i386/dag/repodata/filelists.xml.gz
wget --cache=off http://apt.sw.be/fedora/4/en/i386/dag/repodata/primary.xml.gz
wget --cache=off http://apt.sw.be/fedora/4/en/i386/dag/repodata/repomd.xml
wget --cache=off http://ayo.freshrpms.net/fedora/linux/4/i386/core/repodata/repomd.xml

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4 and yum-2.4.0-0.fc4

How reproducible:
Sometimes

Steps to Reproduce:
1. Doing "yum update" as root.
2.
3.
  

Expected Results:  yum updates system with no errors.

Additional info:
Comment 1 Seth Vidal 2005-10-27 10:45:38 EDT

*** This bug has been marked as a duplicate of 171881 ***

Note You need to log in before you can comment on or make changes to this bug.