Bug 1718826 - Rebase OpenSCAP in RHEL 8.1 to the latest upstream version
Summary: Rebase OpenSCAP in RHEL 8.1 to the latest upstream version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: openscap
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.1
Assignee: Jan Černý
QA Contact: Matus Marhefka
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-10 10:27 UTC by Jan Černý
Modified: 2019-11-05 21:15 UTC (History)
7 users (show)

Fixed In Version: openscap-1.3.1-1.el8
Doc Type: Enhancement
Doc Text:
.OpenSCAP rebased to version 1.3.1 The `openscap` packages have been upgraded to upstream version 1.3.1, which provides many bug fixes and enhancements over the previous version, most notably: * Support for SCAP 1.3 source data streams: evaluating, XML schemas, and validation * Tailoring files are included in ARF result files * OVAL details are always shown in HTML reports, users do not have to provide the `--oval-results` option * HTML report displays OVAL test details also for OVAL tests included from other OVAL definitions using the OVAL `extend_definition` element * OVAL test IDs are shown in HTML reports * Rule IDs are shown in HTML guides
Clone Of:
Environment:
Last Closed: 2019-11-05 21:15:41 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3445 None None None 2019-11-05 21:15:43 UTC

Description Jan Černý 2019-06-10 10:27:52 UTC
Description of problem:

Latest upstream version of OpenSCAP fixes bugs reported in RHEL and provides new features requested by customers and community. It also fixes a large amount of issues reported upstream. The API/ABI is fully compatible with previous release shipped in RHEL 8.0.

Notable changes are: Support for SCAP 1.3 datastreams, fixed generation of Ansible playbooks, fixed scanning remote filesystems.

Version-Release number of selected component (if applicable):
-

How reproducible:
always

Steps to Reproduce:
1. rpm -q openscap

Actual results:
Outdated version of OpenSCAP.


Expected results:
Latest upstream version of OpenSCAP.


Additional info:
-

Comment 1 Jan Černý 2019-06-13 11:11:16 UTC
A new version has been released in upstream:
https://github.com/OpenSCAP/openscap/releases/tag/1.3.1

Comment 6 errata-xmlrpc 2019-11-05 21:15:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3445


Note You need to log in before you can comment on or make changes to this bug.