Bug 171890 - fedora ia64 fails to boot after kzalloc failure
fedora ia64 fails to boot after kzalloc failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2005-10-27 10:41 EDT by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 22:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2005-10-27 10:41:47 EDT
Description of problem:

The current builds of fedora ia64 fail to boot after kzalloc inexplicably fails.

Version-Release number of selected component (if applicable): Latest rawhide builds


How reproducible: 100%


Steps to Reproduce:
1. Boot latest kernels
  
Actual results:

Freeing initrd memory: 1968kB freed
kernel BUG at kernel/workqueue.c:572!
swapper[1]: bugcheck! 0 [1]
Modules linked in:

Pid: 1, CPU 0, comm:              swapper
psr : 00001010085a6010 ifs : 8000000000000186 ip  : [<a0000001000a8f00>]    Not
tainted
ip is at init_workqueues+0xa0/0xc0
unat: 0000000000000000 pfs : 0000000000000186 rsc : 0000000000000003
rnat: a0000001009af534 bsps: 00000000000046dc pr  : 0000000000009941
ldrs: 0000000000000000 ccv : 0000000000000000 fpsr: 0009804c8a70433f
csd : 0000000000000000 ssd : 0000000000000000
b0  : a0000001000a8f00 b6  : e000003002385bf0 b7  : a000000100394f00
f6  : 1003e000000047d155f28 f7  : 1003e20c49ba5e353f7cf
f8  : 1003e00000000000000c8 f9  : 10006c7fffffffd73ea5c
f10 : 0fffdfffffffffaf00000 f11 : 1003e0000000000000000
r1  : a000000100ae3840 r2  : 0000000000000000 r3  : e00004307bcd8d94
r8  : 0000000000000029 r9  : a0000001008f07d8 r10 : 0000000000000001
r11 : a0000001008135c0 r12 : e00004307bcdfde0 r13 : e00004307bcd8000
r14 : 0000000000004000 r15 : 0000000000000000 r16 : ffffffffdead4ead
r17 : a0000001008135a8 r18 : a0000001008e3a48 r19 : a0000001008f07b0
r20 : a0000001008f8008 r21 : a0000001008f8008 r22 : e00004307bcdfcb8
r23 : e00004307bcdfcb0 r24 : 0000000000000034 r25 : a0000001009af55b
r26 : 0000000000004703 r27 : 0000000000004703 r28 : 000000000000003e
r29 : 0000000000000000 r30 : a0000001009af55c r31 : e00004307bcd8d94

Call Trace:
 [<a000000100011fc0>] show_stack+0x80/0xa0
                                sp=e00004307bcdf950 bsp=e00004307bcd8f78
 [<a0000001000128d0>] show_regs+0x890/0x8c0
                                sp=e00004307bcdfb20 bsp=e00004307bcd8f30
 [<a00000010003a240>] die+0x140/0x240
                                sp=e00004307bcdfb40 bsp=e00004307bcd8ee8
 [<a00000010003a380>] die_if_kernel+0x40/0x60
                                sp=e00004307bcdfb40 bsp=e00004307bcd8eb8
 [<a0000001006210d0>] ia64_bad_break+0x270/0x740
                                sp=e00004307bcdfb40 bsp=e00004307bcd8e90
 [<a00000010000c840>] ia64_leave_kernel+0x0/0x280
                                sp=e00004307bcdfc10 bsp=e00004307bcd8e90
 [<a0000001000a8f00>] init_workqueues+0xa0/0xc0
                                sp=e00004307bcdfde0 bsp=e00004307bcd8e60
 [<a0000001000098c0>] init+0x320/0xa20
                                sp=e00004307bcdfde0 bsp=e00004307bcd8e20
 [<a000000100014510>] kernel_thread_helper+0x30/0x60
                                sp=e00004307bcdfe30 bsp=e00004307bcd8df0
 [<a0000001000090a0>] start_kernel_thread+0x20/0x40
                                sp=e00004307bcdfe30 bsp=e00004307bcd8df0
 <0>Kernel panic - not syncing: Attempted to kill init!

Expected results:

Panic shouldn't happen.

Additional info:

After some quick investigation, it looks like __create_workqueue's kzalloc
fails.... (I haven't done any investigation beyond that)
Comment 1 Dave Jones 2005-12-28 00:13:40 EST
Any better with latest builds ?
Comment 2 Prarit Bhargava 2006-02-23 13:05:21 EST
No longer an issue. 

Note You need to log in before you can comment on or make changes to this bug.