Bug 171895 - multipath fails in rc.sysinit with library missing error
multipath fails in rc.sysinit with library missing error
Status: CLOSED DUPLICATE of bug 168321
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2005-10-27 11:52 EDT by Thomas Krieger
Modified: 2014-03-16 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-27 13:15:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas Krieger 2005-10-27 11:52:01 EDT
Description of problem:

During system startup in rc.sysinit multipath devices are loaded. This only 
works if /usr is not mounted on a seperate partition. The following instruction 
is executed: /sbin/multipath -v 0. Unfortunately /sbin/multipath is linked 
dynamically and therefore the execution failed with libsysfs.so.1 missing 
because this library is located in /usr/lib!

In my opinion there are two possible solutions to solve this bug:
1.) locate libsysfs.so.1 in /lib
2.) use /bin/multipath.static instead of /sbin/multipath in rc.sysinit.

Version-Release number of selected component (if applicable):

How reproducible:
Setup a host and mount /usr to a seperate partition

Actual results:
/usr mounted on seperate partition setup of multipath devices fails
/usr located in the root filesystem setup of multipath devices works as expected
Comment 1 Bill Nottingham 2005-10-27 13:15:35 EDT

*** This bug has been marked as a duplicate of 168321 ***

Note You need to log in before you can comment on or make changes to this bug.