Bug 1718968 - startxfce4 fails with 'Unrecognized option: --'
Summary: startxfce4 fails with 'Unrecognized option: --'
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-10 16:06 UTC by bob53181
Modified: 2020-05-26 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 16:33:58 UTC
Type: Bug


Attachments (Terms of Use)
Redirected stderr to a log file (6.26 KB, text/plain)
2019-06-10 16:06 UTC, bob53181
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 15618 None None None 2019-07-04 11:21:41 UTC

Description bob53181 2019-06-10 16:06:19 UTC
Created attachment 1579092 [details]
Redirected stderr to a log file

Description of problem:

When I run startxfce4, it fails with the error 'Unrecognized option: --'.

Version-Release number of selected component (if applicable):

xfce4-session-4.13.1-23.fc30.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. run startxfce4
2.
3.

Actual results:

X fails to start

Expected results:

X and XFCE4 start.

Additional info:

There is a question asked on Ask Fedora about a similar problem, in Spanish[1].

If I run `xinit /usr/bin/startxfce4 -- :0 vt1` it starts XFCE4 correctly.

[1]: https://askbot.fedoraproject.org/es/question/128317/fedora-server-29-no-inicia-el-escritorio-xfce/

Comment 1 Mukundan Ragavan 2019-06-10 22:05:02 UTC
Can you file this upstream or would you like that I do?

Comment 2 bob53181 2019-06-11 14:07:05 UTC
You can file it upstream. However this could be Fedora specific as startxfce4 was working fine on Arch as of a week ago. Can you reproduce this on your system?

Comment 3 Mukundan Ragavan 2019-06-12 01:57:50 UTC
I have not had the chance to try this. I will check and report upstream if needed.

Comment 4 bob53181 2019-06-17 21:25:16 UTC
I filed the bug upstream myself - id 15618.

Comment 5 bob53181 2019-06-18 15:30:46 UTC
The problem is Fedora specific. It is because of a Fedora patch [1] conflicting with an XFCE patch [2]. I also applies for the recently released xfce4-session-4.13.2-2.fc30.x86_64. Further discussion can be found on the XFCE bug tracker [3].

[1]: https://src.fedoraproject.org/rpms/xfce4-session/blob/master/f/xfce-session-4.10-startxfce4.patch
[2]: https://git.xfce.org/xfce/xfce4-session/commit/?id=04e45b5bbdefe4e174c95dcbc70a725b8198b50d
[3]: https://bugzilla.xfce.org/show_bug.cgi?id=15618

Comment 6 Mukundan Ragavan 2019-06-18 21:23:36 UTC
I will fix this in the next update.

Comment 7 bob53181 2019-08-12 19:45:26 UTC
The problem persists in xfce4-session-4.13.3-1.fc30 that has been pushed to the Fedora 30 stable repository.

Comment 8 Ben Cotton 2020-04-30 21:22:15 UTC
This message is a reminder that Fedora 30 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 30 on 2020-05-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '30'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 30 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 9 Ben Cotton 2020-05-26 16:33:58 UTC
Fedora 30 changed to end-of-life (EOL) status on 2020-05-26. Fedora 30 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.