Bug 1719 - 09-13.src.rpm in stops in install-stage
09-13.src.rpm in stops in install-stage
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
6.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-23 19:19 EST by oliver.hensel
Modified: 2015-01-07 18:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-10 11:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver.hensel 1999-03-23 19:19:10 EST
instead of searching for texmf.cnf in /usr/share/texmf/web2c
in looks in /usr/lib/texmf/web2c
the problem seems to be with TEXMFMAIN not get properly set

------- Additional Comments From   03/23/99 19:43 -------
this seems to correct it:

--- tetex.spec~ Wed Mar 24 01:27:57 1999
+++ tetex.spec  Wed Mar 24 01:48:01 1999
@@ -180,7 +180,8 @@
 patch -p3 -d $RPM_BUILD_ROOT/usr/share < %{PATCH2}
 mkdir -p $RPM_BUILD_ROOT/var/lib/texmf
 make install prefix=$RPM_BUILD_ROOT/usr \
-       texmf=$RPM_BUILD_ROOT/usr/share/texmf
+       texmf=$RPM_BUILD_ROOT/usr/share/texmf \
+       texmfmain=$RPM_BUILD_ROOT/usr/share/texmf
 #perl -pi \
 #      -e "s|\.\./share/texmf|/usr/share/texmf|g;" \
 #      -e "s|$RPM_BUILD_ROOT/var/lib/texmf|/var/lib/texmf|g;" \

------- Additional Comments From   03/24/99 19:18 -------
this seems to correct it:

--- tetex.spec~ Wed Mar 24 01:27:57 1999
+++ tetex.spec  Wed Mar 24 01:48:01 1999
@@ -180,7 +180,8 @@
 patch -p3 -d $RPM_BUILD_ROOT/usr/share < %{PATCH2}
 mkdir -p $RPM_BUILD_ROOT/var/lib/texmf
 make install prefix=$RPM_BUILD_ROOT/usr \
-       texmf=$RPM_BUILD_ROOT/usr/share/texmf
+       texmf=$RPM_BUILD_ROOT/usr/share/texmf \
+       texmfmain=$RPM_BUILD_ROOT/usr/share/texmf
 #perl -pi \
 #      -e "s|\.\./share/texmf|/usr/share/texmf|g;" \
 #      -e "s|$RPM_BUILD_ROOT/var/lib/texmf|/var/lib/texmf|g;" \
Comment 1 Jeff Johnson 1999-06-10 11:02:59 EDT
I included your change in tetex-1.0.1-2. It *almost* worked,
but left me with texmf.cnf line
	TEXMFMAIN = $SELFAUTOPARENT/share/texmf
that I needed to change to
	TEXMFMAIN = $SELFAUTODIR/share/texmf

(There were some other backward compatibility texmf.cnf problems
issues also so the package carries its own copy rather than installing
the generated file).

Note You need to log in before you can comment on or make changes to this bug.