Bug 1719011 - Manila UI is disabled in Horizon
Summary: Manila UI is disabled in Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Goutham Pacha Ravi
QA Contact: vhariria
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-10 18:55 UTC by vhariria
Modified: 2019-09-26 10:52 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190621130403.3db471f.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
UI screenshot (84.41 KB, image/png)
2019-06-10 19:37 UTC, vhariria
no flags Details
missing tabs_menus from OSP15 horizon UI (74.23 KB, image/png)
2019-07-16 14:56 UTC, Jason Grosso
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1832302 0 None None None 2019-06-11 19:17:40 UTC
OpenStack gerrit 664626 0 None None None 2019-06-11 17:15:46 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:23 UTC

Description vhariria 2019-06-10 18:55:47 UTC
Description of problem:
Manila UI appears broken and is missing in Horizon


Version-Release number of selected component (if applicable):


How reproducible:
100% 

Steps to Reproduce:
1. Deploy Manila with NetApp backend running OSP15
2. On OpenStack Horizon; look for the Shares tab under Project > Compute.

Actual results:
The Shares tab does not exist 

Expected results:
Expect Shares tab under Project > Compute

Additional info:
The issue applies to multiple deployments, including cephFs NFS-Ganesha

Comment 1 vhariria 2019-06-10 19:37:07 UTC
Created attachment 1579155 [details]
UI screenshot

Comment 11 Jason Grosso 2019-07-16 14:56:06 UTC
Created attachment 1591087 [details]
missing tabs_menus from OSP15 horizon UI

Comment 12 Jason Grosso 2019-07-16 14:57:22 UTC
Verified on the OSP15 build RHOS_TRUNK-15.0-RHEL-8-20190714.n.0 we can now see the missing manila horizon tabs

Comment 14 errata-xmlrpc 2019-09-21 11:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.