Bug 171941 - Need to change Directory Console version to 1.0
Summary: Need to change Directory Console version to 1.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Console (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-27 22:58 UTC by Nathan Kinder
Modified: 2015-12-07 17:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 17:11:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (15.35 KB, patch)
2005-10-28 17:38 UTC, Nathan Kinder
no flags Details | Diff
CVS Commit (1.59 KB, text/plain)
2005-10-28 18:01 UTC, Nathan Kinder
no flags Details

Description Nathan Kinder 2005-10-27 22:58:05 UTC
The Directory Console version number needs to be changed to 1.0.  It also needs
to assume that it is working with version 1.0 of the Fedora Management Console.

Comment 1 Nathan Kinder 2005-10-28 17:38:11 UTC
Created attachment 120508 [details]
CVS Diffs

Adjusted the version number and branding.  I had to modify the checkVersion
method to deal with running in Console 1.0.  I also cleaned up references to
"consolesdk" in the Ant build files.  They should be "console" instead since we
dropped the "consolesdk" naming.

Comment 2 Nathan Kinder 2005-10-28 18:01:38 UTC
Created attachment 120511 [details]
CVS Commit

Checked into HEAD.  Reviewed by Noriko.

Comment 3 Nathan Kinder 2005-10-28 22:14:59 UTC
Noriko and I noticed an additional change that is needed for the checkVersion
method.  Here's the change:

Index: DSAdmin.java
===================================================================
RCS file: /cvs/dirsec/directoryconsole/src/com/netscape/admin/dirserv/DSAdmin.java,v
retrieving revision 1.2
diff -u -5 -t -r1.2 DSAdmin.java
--- DSAdmin.java        28 Oct 2005 18:01:34 -0000      1.2
+++ DSAdmin.java        28 Oct 2005 22:15:57 -0000
@@ -1234,11 +1234,11 @@
                 version = VersionInfo.getVersionNumber();
  
                 try {
                         Float f = new Float(version);
                         // Check if the console meets the minimum version
requirement
-                        if ((f != null) && (f.floatValue() > MINIMUM_VERSION)) {
+                        if ((f != null) && (f.floatValue() >= MINIMUM_VERSION)) {
                                 return true;
                         } else {
                                 DSUtil.showErrorDialog(frame, "neednewconsole",
version);


Comment 4 Nathan Kinder 2005-10-28 22:17:13 UTC
Additional checkVersion change checked into HEAD.  Reviewed by Noriko (thanks!).

Checking in DSAdmin.java;
/cvs/dirsec/directoryconsole/src/com/netscape/admin/dirserv/DSAdmin.java,v  <--
 DSAdmin.java
new revision: 1.3; previous revision: 1.2
done

Comment 5 Jenny Galipeau 2011-06-06 18:41:19 UTC
Please add steps to reproduce and verify thanks

Comment 6 Rich Megginson 2011-06-06 19:50:56 UTC
1) run the console
2) open the About... window
3) should report correct version - corresponds to the rpm version

Comment 7 Amita Sharma 2011-06-22 13:33:13 UTC
[root@testvm /]# rpm -qa | grep 389
389-adminutil-1.1.13-1.el6.x86_64
389-console-1.1.4-1.el6.noarch
389-ds-console-doc-1.2.5-1.el6.noarch
389-ds-base-1.2.8.2-1.el6.x86_64
389-admin-1.1.16-2.el6.x86_64
389-ds-console-1.2.5-1.el6.noarch
389-admin-console-doc-1.1.7-1.el6.noarch
389-ds-base-debuginfo-1.2.8.2-1.el6.x86_64
389-ds-base-libs-1.2.8.2-1.el6.x86_64
389-admin-console-1.1.7-1.el6.noarch
389-ds-1.2.1-2.el6.noarch

On Console 1.2.0


Hence VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.