Bug 171945 - /etc/profile gives syntax error when using ksh as login shell
Summary: /etc/profile gives syntax error when using ksh as login shell
Status: CLOSED DUPLICATE of bug 160731
Alias: None
Product: Fedora
Classification: Fedora
Component: setup   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-28 00:04 UTC by ihateredhat
Modified: 2014-03-17 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 00:20:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ihateredhat 2005-10-28 00:04:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
When logging into an FC4 machine when the default shell for the user is set to ksh(pdksh), this error results.

/etc/profile[17]: [: argument expected


Version-Release number of selected component (if applicable):
setup-2.5.44-1.1

How reproducible:
Always

Steps to Reproduce:
1. Set login shell to ksh
2. Log in

  

Actual Results:  /etc/profile[17]: [: argument expected

Expected Results:  no error

Additional info:

Fix line 17 of /etc/profile by adding quotes around $EUID

Original:
# Path manipulation
if [ $EUID = 0 ]; then
        pathmunge /sbin

Change to:
# Path manipulation
if [ "$EUID" = 0 ]; then
        pathmunge /sbin

Comment 1 Bill Nottingham 2005-10-28 00:20:42 UTC

*** This bug has been marked as a duplicate of 160731 ***


Note You need to log in before you can comment on or make changes to this bug.