Bug 171950 - Can't reboot on IBM xSeries 236.
Can't reboot on IBM xSeries 236.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Anderson
Brian Brock
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-27 21:49 EDT by TAIRA Hajime
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHSA-2006-0132
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 15:34:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TAIRA Hajime 2005-10-27 21:49:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
I installed RHEL4 to customer's IBM xSeries 236.
http://www-03.ibm.com/servers/eserver/xseries/x236.html

This customer already bought RHEL subscription.
This server is being certified by IBM for using RHEL4 EM64T Edition.

I couldn't reboot system. But I could halt system.

This trouble generated only on EM64T environment.
It doesn't reproduce it on x86 32bit environment.

I tried following kernel version.
2.6.9-5.ELsmp
2.6.9-11.ELsmp
2.6.9-22.ELsmp

Already I tried following kernel parameter.
acpi=no, acpi=noirq, apm=no

The customer was hurrying up. After it explains enough I installed
RHEL4 x86 32bit Edition. It has been a compromise plan.

Couldn't reboot system on EM64T. It is RHEL4's bug?

Version-Release number of selected component (if applicable):
kernel-2.6.9-5.ELsmp

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4 EM64T to IBM xSeries 236
2.Login to system
3.Reboot system
  

Actual Results:  System displayed "Restarting system." and freezed.

Additional info:
Comment 2 Dave Anderson 2005-10-28 12:15:37 EDT
You first need to try several differnet "reboot=" boot command line options.

/* reboot=b[ios] | t[riple] | k[bd] [, [w]arm | [c]old] | [a]cpi
   bios   Use the CPU reboot vector for warm reset
   warm   Don't set the cold reboot flag
   cold   Set the cold reboot flag
   triple Force a triple fault (init)
   kbd    Use the keyboard controller. cold reset (default)
   acpi   Use the ACPI reset mechanism defined in the FADT
 */

The main options of interest are the 'b', 't', 'k' and 'a' options.

If you do not enter the reboot= option on the boot command line, then
the system will default to 'k'.  However if your system has a certain ACPI
revision, you would see this boot-time message:

  System reset via FADT Reset Register is supported

...and the default would be changed during boot to 'a'.

So, again, without using the reboot= option, the default is either 'k' or 'a',
depending upon your ACPI version.

However, you can override both defaults by using the reboot= command line
option.  So, in order to ensure that all possible reboot options are tested,
you need to try this boot command line options:

  reboot=b
  reboot=t
  reboot=a
  reboot=k

The 'w' and 'c' options tell the BIOS whether it should be a cold or warm
reboot; 'c' is the default.  I don't believe it would help to use the 'w'
flag in conjunction with the above flags, but I really don't know.  So,
if none of the 4 options above help, then you should also try:

  reboot=b,w
  reboot=t,w
  reboot=a,w
  reboot=k,w

I believe that some of this reboot code has changed, so please do your testing
using the latest RHEL4 kernel.
Comment 3 Dave Anderson 2005-10-28 13:29:28 EDT
One other thing to test, to rule out any SMP-related issues.

1. boot the EM64T kernel with the command line option "maxcpus=0", which
   will disable SMP activation.
2. then reboot to see if the system still hangs.

We don't have any of these systems available here, so there's little
else I can suggest.

Comment 4 TAIRA Hajime 2005-10-31 00:31:03 EST
Thank you for reply.
But I do not have this server now.
I passed the torch to IBM Japan.
Comment 5 Dave Anderson 2005-11-01 15:40:49 EST

*** This bug has been marked as a duplicate of 166888 ***
Comment 7 Red Hat Bugzilla 2006-03-07 15:34:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0132.html
Comment 8 Sergey 2006-04-18 08:38:15 EDT
Hello,
Just for information: this promlem reprodusable on IBMs x336 & x346 (both EM64T) 
with RHEL 4 WS Update 3 x86_64

Note You need to log in before you can comment on or make changes to this bug.