Bug 171964 - app icon(s) should follow fdo icon spec
app icon(s) should follow fdo icon spec
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 09:15 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 20:59:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-28 09:15:40 EDT
In order to follow the freedesktop.org Icon spec, gnumeric's icon(s) (currently
only a 48x48 icon) should be installed to
%%_datadir/icons/hicolor/48x48/apps/gnumeric.png

gnumeric.desktop should refer to it as:
Icon=gnumeric

And gnumeric.spec should include:
%post
touch --no-create %{_datadir}/icons/hicolor ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:

%postun
touch --no-create %{_datadir}/icons/hicolor ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:


Also, /usr/share/pixmaps is for legacy ( <= fc3) desktops, and could probably be
dropped in newer versions (targetted for fc4+)
Comment 1 Hans de Goede 2005-11-30 14:05:57 EST
This has been fixed in gnumeric-1.6.1-1 which should show up on a mirror near
you soon.
Comment 2 Brian Pepple 2006-01-20 15:53:52 EST
The desktop file needs to be corrected for this change.
Comment 3 Brian Pepple 2006-01-20 20:59:12 EST
Disregard comment #2, looks like it took a while for the icon cache to refresh.
Comment 4 Hans de Goede 2006-01-21 03:10:35 EST
Actually you did find a bug, the %post script of the rpm should call
gtk-update-icon-cache

This has been fixed in CVS, I'll build it a soon as the buildsys is back up.
Comment 5 Hans de Goede 2006-01-24 06:12:20 EST
FYI A new package which does call gtk-update-icon-cache in %post has been build.

Note You need to log in before you can comment on or make changes to this bug.