Bug 171966 - SSH-tunneled X11 program exits with 'BadAtom' error
SSH-tunneled X11 program exits with 'BadAtom' error
Status: CLOSED DUPLICATE of bug 150262
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 09:45 EDT by Timophey Kushnir
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 09:54:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timophey Kushnir 2005-10-28 09:45:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):
All recent xorg-x11 packages.


How reproducible:
Always


Steps to Reproduce:
1. SSH to other machine with X11Forward on.
2. Start scadesktop program from Scali SSP 4.4.x
  
Actual results:
scadesktop exits with the following error

$ scadesktop
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0x18e
  Serial number of failed request:  12
  Current serial number in output stream:  15


Expected results:
Normal scadesktop GUI start

Additional info:
N/A
Comment 1 Tomas Mraz 2005-10-31 07:56:07 EST
Does ssh -Y host resolve the problem?
Comment 2 Timophey Kushnir 2005-10-31 09:45:04 EST
(In reply to comment #1)
> Does ssh -Y host resolve the problem?
> 

Yes, it does.
Why normal X11Forward doesn't do the same?
Comment 3 Tomas Mraz 2005-10-31 09:54:46 EST
See the duplicate bug report.


*** This bug has been marked as a duplicate of 150262 ***

Note You need to log in before you can comment on or make changes to this bug.