Bug 171968 - aio_suspend is not interrupted by the signal
aio_suspend is not interrupted by the signal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 10:42 EDT by Elena Vengerova
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.3.90-28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 11:41:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena Vengerova 2005-10-28 10:42:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
aio_suspend() is not interrupted by the signal

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create and bind UDP socket.
2. Post read AIO request using aio_read().
3. Install signal handler for SIGUSR1.
4. Call aio_suspend() with some timeout.
5. Send to process signal SIGUSR1.
  

Actual Results:  aio_suspend() does not resume until timeout expires.

Expected Results:  aio_suspend() should resume immediately after signal receiving and set errno to EINTR.

Additional info:
Comment 1 Elena Vengerova 2005-11-06 09:27:59 EST
The same is for lio_listio().
Comment 2 Ulrich Drepper 2006-01-06 00:16:04 EST
Due to the implementation interrupts indeed did were not reported.  This is
fixed in the upstream sources and should be in the next rawhide release.  But
once again, aio is not defined for sockets.
Comment 3 Jakub Jelinek 2006-01-06 11:41:21 EST
Should be fixed in glibc-2.3.90-28 and above.

Note You need to log in before you can comment on or make changes to this bug.