Bug 1719756 - Deployment with custom network fails with "resources.VipPort.properties.fixed_ips[0].subnet: Error validating value 'internal_api_subnet': Unable to find subnet with name or id 'internal_api_subnet'"
Summary: Deployment with custom network fails with "resources.VipPort.properties.fixed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: RHOS Maint
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-12 13:27 UTC by Alexander Chuzhoy
Modified: 2019-09-26 10:52 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190627050406.22ee26f.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 665033 0 'None' MERGED Fix RedisVirtualIP when overrdiing InternalApi name_lower 2020-09-13 11:21:25 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:23 UTC

Description Alexander Chuzhoy 2019-06-12 13:27:41 UTC
Deployment with custom network fails with "resources.VipPort.properties.fixed_ips[0].subnet: Error validating value 'internal_api_subnet': Unable to find subnet with name or id 'internal_api_subnet'"

Environment:
openstack-tripleo-heat-templates-10.5.1-0.20190606110437.b9992d9.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190529050408.f172dd6.el8ost.noarch


Steps to reproduce:
Attempt to deploy OC with custom network names.

Deployment command:
openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack overcloud \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /home/stack/virt/config_lvm.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-n /home/stack/virt/network/network_data.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/network/dvr-override.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e ~/containers-prepare-parameter.yaml



The content of network_data.yaml:
- name: Storage
  vip: true
  vlan: 30
  name_lower: MyStorageNet
  service_net_map_replace: storage
  ip_subnet: '172.16.1.0/24'
  allocation_pools: [{'start': '172.16.1.4', 'end': '172.16.1.250'}]
  ipv6_subnet: 'fd00:fd00:fd00:3000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:3000::10', 'end': 'fd00:fd00:fd00:3000:ffff:ffff:ffff:fffe'}]
  mtu: 1500
- name: StorageMgmt
  name_lower: MyStorageMgmtNet
  service_net_map_replace: storage_mgmt
  vip: true
  vlan: 40
  ip_subnet: '172.16.3.0/24'
  allocation_pools: [{'start': '172.16.3.4', 'end': '172.16.3.250'}]
  ipv6_subnet: 'fd00:fd00:fd00:4000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:4000::10', 'end': 'fd00:fd00:fd00:4000:ffff:ffff:ffff:fffe'}]
  mtu: 1500
- name: InternalApi
  name_lower: MyInternalApiNet
  service_net_map_replace: internal_api
  vip: true
  vlan: 20
  ip_subnet: '172.16.2.0/24'
  allocation_pools: [{'start': '172.16.2.4', 'end': '172.16.2.250'}]
  ipv6_subnet: 'fd00:fd00:fd00:2000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:2000::10', 'end': 'fd00:fd00:fd00:2000:ffff:ffff:ffff:fffe'}]
  mtu: 1500
- name: Tenant
  vip: false  # Tenant network does not use VIPs
  name_lower: MyTenantNet
  service_net_map_replace: tenant
  vlan: 50
  ip_subnet: '172.16.0.0/24'
  allocation_pools: [{'start': '172.16.0.4', 'end': '172.16.0.250'}]
  ipv6_subnet: 'fd00:fd00:fd00:5000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:5000::10', 'end': 'fd00:fd00:fd00:5000:ffff:ffff:ffff:fffe'}]
  mtu: 1500
- name: External
  vip: true
  name_lower: MyExternalNet
  service_net_map_replace: external
  vlan: 10
  ip_subnet: '10.0.0.0/24'
  allocation_pools: [{'start': '10.0.0.4', 'end': '10.0.0.250'}]
  gateway_ip: '10.0.0.1'
  ipv6_subnet: '2001:db8:fd00:1000::/64'
  ipv6_allocation_pools: [{'start': '2001:db8:fd00:1000::10', 'end': '2001:db8:fd00:1000:ffff:ffff:ffff:fffe'}]
  gateway_ipv6: '2001:db8:fd00:1000::1'
  mtu: 1500
- name: Management
  # Management network is enabled by default for backwards-compatibility, but
  # is not included in any roles by default. Add to role definitions to use.
  enabled: true
  vip: false  # Management network does not use VIPs
  name_lower: management
  vlan: 60
  ip_subnet: '10.0.1.0/24'
  allocation_pools: [{'start': '10.0.1.4', 'end': '10.0.1.250'}]
  gateway_ip: '10.0.1.1'
  gateway_ipv6: 'fd00:fd00:fd00:6000::1'
  ipv6_subnet: 'fd00:fd00:fd00:6000::/64'
  ipv6_allocation_pools: [{'start': 'fd00:fd00:fd00:6000::10', 'end': 'fd00:fd00:fd00:6000:ffff:ffff:ffff:fffe'}]
  mtu: 1500



The content of network-environment.yaml:
parameter_defaults:
    ControlPlaneDefaultRoute: 192.168.24.1
    ControlPlaneSubnetCidr: '24'
    DnsServers:
    - 10.0.0.1
    EC2MetadataIp: 192.168.24.1
    ExternalAllocationPools:
    -   end: 10.0.0.149
        start: 10.0.0.101
    ExternalInterfaceDefaultRoute: 10.0.0.1
    ExternalNetCidr: 10.0.0.0/24
    ExternalNetworkVlanID: 10
    InternalApiAllocationPools:
    -   end: 172.17.1.149
        start: 172.17.1.10
    InternalApiNetCidr: 172.17.1.0/24
    InternalApiNetworkVlanID: 20
    NeutronBridgeMappings: datacentre:br-ex,tenant:br-isolated
    NeutronExternalNetworkBridge: br-ex
    NeutronNetworkType: geneve
    NeutronNetworkVLANRanges: tenant:1000:2000
    NeutronTunnelTypes: geneve
    StorageAllocationPools:
    -   end: 172.17.3.149
        start: 172.17.3.10
    StorageMgmtAllocationPools:
    -   end: 172.17.4.149
        start: 172.17.4.10
    StorageMgmtNetCidr: 172.17.4.0/24
    StorageMgmtNetworkVlanID: 40
    StorageNetCidr: 172.17.3.0/24
    StorageNetworkVlanID: 30
    TenantAllocationPools:
    -   end: 172.17.2.149
        start: 172.17.2.10
    TenantNetCidr: 172.17.2.0/24
    TenantNetworkVlanID: 50
resource_registry:
    OS::TripleO::BlockStorage::Net::SoftwareConfig: three-nics-vlans//cinder-storage.yaml
    OS::TripleO::CephStorage::Net::SoftwareConfig: three-nics-vlans//ceph-storage.yaml
    OS::TripleO::Compute::Net::SoftwareConfig: three-nics-vlans//compute.yaml
    OS::TripleO::Controller::Net::SoftwareConfig: three-nics-vlans//controller.yaml
    OS::TripleO::ObjectStorage::Net::SoftwareConfig: three-nics-vlans//swift-storage.yaml





Result:

The deployment fails with:
overcloud.RedisVirtualIP:
  resource_type: OS::TripleO::Network::Ports::RedisVipPort
  physical_resource_id: 
  status: CREATE_FAILED
  status_reason: |
    resources.RedisVirtualIP: Property error: resources.VipPort.properties.fixed_ips[0].subnet: Error validating value 'internal_api_subnet': Unable to find subnet with name or id 'internal_api_subnet'
(undercloud) [stack@undercloud-0 ~]$

Comment 2 Bob Fournier 2019-06-18 20:23:03 UTC
Temporarily removing blocker flag.

Comment 7 Bob Fournier 2019-07-02 13:24:03 UTC
Moving to ON_QA similar to https://bugzilla.redhat.com/show_bug.cgi?id=1719897 as they have the same FixedInVersion.

Comment 8 Alexander Chuzhoy 2019-07-02 20:16:13 UTC
Verified:
Environment:
openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost.noarch

Was able to deploy OC with custom network names:

(undercloud) [stack@undercloud-0 ~]$ openstack network list
+--------------------------------------+------------------+--------------------------------------+
| ID                                   | Name             | Subnets                              |
+--------------------------------------+------------------+--------------------------------------+
| 1023faba-b1a8-47bb-8770-aaff8f2efb0f | MyStorageMgmtNet | 3d5d51f1-8ef0-44ce-a11c-37b8cc1de51d |
| 263f431f-aaa1-4ef2-99fc-51d1360c66bd | MyStorageNet     | 58ec3004-bcd5-4eb1-ac39-e1e7d47b7568 |
| 41099f37-999d-47bc-b220-c2cfd8e84243 | management       | 8c0cb99f-28f6-4f12-ac8f-e8300b9ff81f |
| 55349c7c-4e06-41f6-bffc-9973e9f1ab4a | MyInternalApiNet | 2c176993-e8fb-4ccb-b76d-311d270e0461 |
| 799167a0-e881-4c73-a370-1f79cbe55e3d | MyExternalNet    | 415c4d7c-e922-4369-8d2d-88d9686b9c03 |
| 92ee6e20-3389-40b5-9b9b-3299fc0d6713 | ctlplane         | c96d70e9-bbae-40a8-a175-5604476e3166 |
| ae464f6a-e5d7-46b4-a143-e904fe19562f | MyTenantNet      | 37c1b487-a423-4dea-af74-9c6cbb4a9424 |
+--------------------------------------+------------------+--------------------------------------+

Comment 10 errata-xmlrpc 2019-09-21 11:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.