Bug 171978 - Does not cleanly uninstall in devel
Summary: Does not cleanly uninstall in devel
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mathml-fonts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-28 16:13 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 16:25:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael A. Peters 2005-10-28 16:13:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
fontconfig in rawhide creates a fonts.cache-2 file in addition to fonts.cache-1

That file needs to ghosted so that it removes on uninstall

Version-Release number of selected component (if applicable):
mathml-fonts-1.0-19.fc5

How reproducible:
Always

Steps to Reproduce:
1. rpm -e mathml-fonts
2.
3.
  

Actual Results:  /usr/share/fonts/mathml directory containing fonts.cache-2 is left behind

Expected Results:  clean uninstall

Additional info:

I'm cc-ing the list because I suspect other font packages in Extras also have this problem. Solution is to touch the fonts.cache-2 and then ghost it.

Comment 1 Rex Dieter 2005-10-28 16:25:05 UTC
Thanks for the heads-up.  fixed.

Comment 2 Nicolas Mailhot 2005-10-28 16:26:08 UTC
Thanks for the CC - will fix dejavu now

Comment 3 Sarantis Paskalis 2005-10-31 12:46:01 UTC
mgopen-fonts fixed.

Comment 4 Dawid Gajownik 2005-10-31 13:09:50 UTC
I'll fix hunky-fonts after creating FC-4 branch.


Note You need to log in before you can comment on or make changes to this bug.