Bug 1719802 - Deployment fails with ERROR: The Resource Type (OS::TripleO::Services::PlacementApi) could not be found
Summary: Deployment fails with ERROR: The Resource Type (OS::TripleO::Services::Placem...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Giulio Fidente
QA Contact: Eliad Cohen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-12 15:02 UTC by Eliad Cohen
Modified: 2019-10-22 10:27 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190619000409.eff8376.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Undercloud files excluding var folder (1.54 MB, application/x-xz)
2019-06-12 15:02 UTC, Eliad Cohen
no flags Details
undercloud var folder (4.79 MB, application/x-xz)
2019-06-12 15:03 UTC, Eliad Cohen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1832748 0 None None None 2019-06-13 17:17:49 UTC
OpenStack gerrit 665177 0 None None None 2019-06-13 16:51:55 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:23 UTC

Description Eliad Cohen 2019-06-12 15:02:43 UTC
Created attachment 1579857 [details]
Undercloud files excluding var folder

Description of problem:
OSP15/Ganesha/ceph deployment fails with error [1]



Version-Release number of selected component (if applicable):


How reproducible:
Deployment command[2]

Steps to Reproduce:
1. Deploy the env. [1]
2.
3.

Actual results:
Error

Expected results:
Should complete successfully

Additional info: 
[1] http://pastebin.test.redhat.com/771202
[2] http://pastebin.test.redhat.com/771206

Comment 1 Eliad Cohen 2019-06-12 15:03:57 UTC
Created attachment 1579858 [details]
undercloud var folder

Comment 3 Alex Schultz 2019-06-13 00:07:48 UTC
Are you using the ContorllerStorageNfs.yaml role?  If so, that role should not have PlacementApi defined for OSP15. We do not have a PlacementApi in OSP15, it should only be NovaPlacement.

Comment 4 Eliad Cohen 2019-06-13 15:08:41 UTC
(In reply to Alex Schultz from comment #3)
> Are you using the ContorllerStorageNfs.yaml role?  If so, that role should
> not have PlacementApi defined for OSP15. We do not have a PlacementApi in
> OSP15, it should only be NovaPlacement.

Yes, that is the role I am using. And I see PlacementApi is defined under the role in roles_data.yaml even though this is not defined in the upstream role file.

Comment 12 Eliad Cohen 2019-06-25 20:41:35 UTC
Verified PlacementApi absent (and NovaPlacement present)

Comment 16 errata-xmlrpc 2019-09-21 11:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.