Bug 171995 - ATI (Radeon X300SE) not recognized
ATI (Radeon X300SE) not recognized
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 16:37 EDT by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 17:24:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (1.38 KB, text/plain)
2005-10-28 16:39 EDT, Gene Czarcinski
no flags Details
lspci -v (7.60 KB, text/plain)
2005-10-28 16:39 EDT, Gene Czarcinski
no flags Details
lspci -n (714 bytes, text/plain)
2005-10-28 16:40 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2005-10-28 16:37:57 EDT
Description of problem:
I have a couple of systems I am testing with development.  The first has a ATI
Technologies Inc Radeon R200 QM [Radeon 9100] (rev 80) [this works fine].  The
second has a ATI Technologies Inc RV370 [Radeon X300SE] PCIE card [this is not
recognized].

Both systems work fine with Fedora Core 4 (updated to current errata).

While the first system loads the radeon driver module, the second does not.

Various lscpi output attached.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-56 (10.28.2005 install of development)
Comment 1 Gene Czarcinski 2005-10-28 16:39:04 EDT
Created attachment 120518 [details]
lspci
Comment 2 Gene Czarcinski 2005-10-28 16:39:35 EDT
Created attachment 120519 [details]
lspci -v
Comment 3 Gene Czarcinski 2005-10-28 16:40:01 EDT
Created attachment 120520 [details]
lspci -n
Comment 4 Gene Czarcinski 2005-10-29 13:23:14 EDT
I manually copied xorg.conf from a "working" FC4 system (different partition,
same  hardware) and this works! ... I am not using the radeon driver it it works
fine ... I am closing this notabug but may open a report against
system-config-display for choosing the vesa driver rather than radeon.
Comment 5 Phil Knirsch 2006-02-10 08:27:00 EST
Have you tried with the latest versions of FC-Devel?

The Radeon X300SE is still in pci.ids, so that shouldn't be the problem.

My guess is that the newer xorg-x11 doesn't detect the card properly because all
the graphics card information has moved over to that package.

Read ya, Phil
Comment 6 Mike A. Harris 2006-02-10 17:24:51 EST
In current Fedora development, the hwdata package no longer provides the
PCI ID to video driver mapping functionality.  This functionality has been
moved into individual "videoalias" files in each individual video driver
rpm package.  "radeon.xinf" is the videoalias file for all Radeon hardware
which is included in xorg-x11-drv-ati.

Here's your video card, from the lspci output above:

01:00.0 Class 0300: 1002:5b60

I just checked radeon.xinf, and this card is currently listed as:
alias pcivideo:v00001002d00005B60sv*sd*bc*sc*i* radeon

So this card should be properly autodetected with the current rawhide packages,
however it may not have been detected correctly at the time this bug report
was initially filed.

Please upgrade all components to the latest rawhide packages, and the
problem should be resolved now.  Be sure to run
"system-config-display --reconfig" to kick in the new autodetection.

There are some people reporting problems still with Radeon hardware being
configured incorrectly, which seems to be a bug in kudzu.  If you encounter
any problem with autodetection after upgrading and reconfiguring, please
reopen the bug report and attach your X server log and config from the
newest packages, and we'll review them to determine if it is the same
kudzu problem.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.