Bug 1720 - SVGA device driver
SVGA device driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 3595 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-23 19:32 EST by paula.laudino
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-30 13:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paula.laudino 1999-03-23 19:32:46 EST
Hello I am desparatly trying to install the CD I received
from LinuxWorld, RedHat 5.2 but the video driver XFree86-
SVGA-3.3.3.1-1.i386 does not work. I pulled down the same
version from your website and the same messed up X windows
for startx still occured. I looked at my video card and it
is an S3 Virge/GX 86C386 OEM for Compaq. I had to revert to
the SVGA16 driver, but it is inefficient. I have tried all
the drivers for S3 and SVGA. Do you have one that will work
with my video card.
Paula Laudino
Comment 1 paula.laudino 1999-03-29 16:33:59 EST
any inof on this bug? Paula Laudino
Comment 2 Preston Brown 1999-03-30 17:03:59 EST
Unfortunately, this isn't really a bug report, but rather a support
request.  Without further information on the specific nature of your
bug, we cannot resolve the issue.

------- Email Received From  Paula.Laudino@BankAmerica.com 03/30/99 18:10 -------
Comment 3 paula.laudino 1999-03-31 14:18:59 EST
As far as I am concerned this is not resloved. Let me state this
again. I have an OEM S3Virger/GX 86C385 9729 54353 Video card in my
PC a Compaq 4000. During the install autoprobe detected the video car
to be SVGA gx which was loaded. In issueing startx after the
confiuration the graphical screen becomes distorted when trying to
move the window and there is a graphical box that seems to be
attached to the screen mnouse pointer. The only option I have left is
to replace the video card, which shouldn't be so in order for this to
work it is in the list of supported devices, come'on now. Also there
are other problems but we won't get into that. I need to know why
this doesn't work and I am beginning to question the minimal support
for RedHat as well. Also of this is not a trouble ticket bug, then
what is it???????? PL

------- Additional Comments From   06/26/99 17:31 -------
Also see bug #3595  SH
Comment 4 Jay Turner 1999-06-29 14:28:59 EDT
*** Bug 3595 has been marked as a duplicate of this bug. ***

This is to confirm bug #1720 using RedHat 6.0 -- exactly as
described for RedHat 5.2.  We have over 100 Compaq DeskPro
4000's with the S3 Virge/GX video cards on site, and all
that we have tried RedHat Linux 6.0 on have the same video
problems, rendering the graphics interface close to useless.
Any help available?Try the XFree86-3.3.3.1-52 build of X and let us know if you are still
having problems.  We have a ton of S3 Virge/GX cards here in the test
lab and have no problems with any of them, so I am thinking that the
problem may very well be with the Deskpro 4000s, which we do not have
an example of in the test lab.
Comment 5 David Lawrence 1999-06-30 13:54:59 EDT
XFree86 decided a while back to roll over most of the S3 support into
the SVGA server instead of the separate S3 server as before. Therefore
the Red Hat installer and Xconfigurator normally by default install
the SVGA server for most S3 cards that it probes. This works in most
cases but Red Hat also still ships the latest S3 server for the cases
in which it does not. Therefore I would suggest installing the S3
server and see if that works better for the cards that you have
installed in your systems. Please mount  your Red Hat cd and then

rpm -Uvh /mnt/cdrom/RedHat/RPMS/XFree86-S3V-3.3.3.1-49.i386.rpm

and then run

Xconfigurator --expert

Choose unlisted card from the card list and then choose the S3V server
choice. You can then answer the rest of the questions. If this still
fails to work reopen the bug and we will have to try and find a
S3Virge card of the same revision number that you have because it
could have changed with out changing the actual model of the card
therrefore causing the failure.

------- Additional Comments From   06/30/99 18:44 -------
Thank you for the advice. The S3V driver worked fine, and the
XFree86-SVGA-3.3.3.1-52 did not.  Except for the fact that the RedHat
Install program does not give users the option to choose the S3V
driver, and that for both the board type (S3 Virge/GX) and the chipset
on the board (S3 86C385) the specs call for only the SVGA driver, one
part of the issue seems resolved.  Perhaps a correction in the install
program and/or XFree86 documentation and/or the SVGA driver is needed
to allow for situations where the stated specs do not work.

Still unresolved is the fact that after the S3V driver is turned off
and the video is returned to text mode, characters are scattered all
over the screen.  The screen is basically unreadable except through a
great deal of cryptography.  I realize that if users are involved with
graphics exclusively this is not an issue.  However, those of us who
would like to switch back and forth for multiple text and graphics
log-in sessions are not allowed to, reducing the full usefulness of
the Linux package.  SH

Note You need to log in before you can comment on or make changes to this bug.