Bug 17200 - mount -t nfs -o remount does not refresh NFS handle
mount -t nfs -o remount does not refresh NFS handle
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
low Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-03 02:06 EDT by Roman Czyborra
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 16:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Czyborra 2000-09-03 02:06:44 EDT
This is more of an old kernel bug inherited from BSD/SunOS:

After trading an NFS partition on a Solaris server, I get:

# strace -e mount mount -o remount /loc
mount("loc:/loc", "/loc", "nfs", MS_REMOUNT|0xc0ed0000, 0x8057620) = 0

Yet nothing is remounted, we are still looking at the old partition:

# df -h /loc
Filesystem            Size  Used Avail Use% Mounted on
loc:/loc               29G   29G  949M  97% /loc
# touch /loc/share/tmp/test
touch: /loc/share/tmp/test: Read-only file system

Workaround:

# umount /loc
# mount /loc
# df -h /loc | tee /loc/share/tmp/test
Filesystem            Size  Used Avail Use% Mounted on
loc:/loc               36G   29G  7.7G  79% /loc
Comment 1 Bernhard Rosenkraenzer 2000-10-04 07:10:03 EDT
Assigning to kernel, since it happens with just the syscall, as well.
Comment 2 Alan Cox 2003-06-05 16:21:17 EDT
Works ok in newer kernels
Comment 3 Alan Cox 2003-06-05 16:22:28 EDT
Ah wait, if you change the server side stuff it can fail. Remount remounts an
existing handle be it a disk or whatever. The same is true with remounting a
renamed file system

Note You need to log in before you can comment on or make changes to this bug.