Bug 1720119 - Node overview page shows incorrect metrics due to too wide selector
Summary: Node overview page shows incorrect metrics due to too wide selector
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1721146
TreeView+ depends on / blocked
 
Reported: 2019-06-13 07:59 UTC by Filip Brychta
Modified: 2019-10-16 06:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the metrics charts on the node page could incorrectly total usage for more than one node in some circumstances. The node page charts now correctly display the usage only for that node.
Clone Of:
: 1721146 (view as bug list)
Environment:
Last Closed: 2019-10-16 06:32:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:32:16 UTC

Description Filip Brychta 2019-06-13 07:59:49 UTC
Description of problem:
Metrics on node overview page are defined following way (e.g. for memory):
node_memory_Active_bytes{instance=~'.*10.0.149.13.*'}

Problem is in '.*10.0.149.13.*'
We have two nodes named:
host-10-0-149-13
host-10-0-149-136

with IPs:
10.0.149.13
10.0.149.136

So the '.*10.0.149.13.*' selector matches both nodes and UI console shows on node overview page for host-10-0-149-13 incorrect metrics which are relevant for  other host host-10-0-149-136.

Version-Release number of selected component (if applicable):
4.1.0
Kubernetes Master Version
    v1.13.4+838b4fa

How reproducible:
Always

Steps to Reproduce:
1. have two nodes named as described above with described IPs (not sure if names or IPs are relevant for the {instance=~'.*10.0.149.13.*'} expr)
2. go to node overview in UI console for host-10-0-149-13


Actual results:
node overview page for host-10-0-149-13 shows incorrect metrics which are relevant for other host host-10-0-149-136.

Expected results:
Metrics for host-10-0-149-13 node should be shown.

Comment 3 Samuel Padgett 2019-06-14 20:26:07 UTC
https://github.com/openshift/console/pull/1726

Comment 5 shahan 2019-06-26 05:34:06 UTC
The node selector is' ${nodeIp.address}:.*'
click one metrics such as Memory Usage on web console, it will got selector like node_memory_Active_bytes{instance=~'10.0.142.139:.*'}
Verify this bug.

4.2.0-0.nightly-2019-06-24-160709
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:24d772dd515d16c28d13de6c349659df0d9807aabb512a25b49d51df82de26d2

Comment 7 errata-xmlrpc 2019-10-16 06:32:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.