Bug 1720232 - RFE: Add /afs to the base filesystem package
Summary: RFE: Add /afs to the base filesystem package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-13 12:57 UTC by David Howells
Modified: 2019-06-20 13:57 UTC (History)
4 users (show)

Fixed In Version: filesystem-3.12-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-20 13:57:46 UTC
Type: Bug


Attachments (Terms of Use)
Patch to add /afs to the filesystem base (1.61 KB, patch)
2019-06-13 12:57 UTC, David Howells
no flags Details | Diff
Patch to add /afs to a filesystem subpackage (2.04 KB, patch)
2019-06-13 12:59 UTC, David Howells
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Fedora Pagure packaging-committee issue 888 None None None 2019-06-13 12:57:33 UTC

Description David Howells 2019-06-13 12:57:34 UTC
Created attachment 1580266 [details]
Patch to add /afs to the filesystem base

Description of problem:

Add /afs to the base filesystem package.  It has been approved by the Fedora packaging committee (bug 888):

    #888 How to install "/afs" directory for kafs-client package
    (geppetto, 16:06:25)
    ACTION: Allow /afs to be included in filesystem, or afs-filesystem
    if desired, for rawhide/f31 (+1:6, 0:0, -1:0) (geppetto, 16:19:07)
    Can use the scriptlet dir. creation hack for f30, but not f31+
    (geppetto, 16:19:36)

This is needed to make it possible to do the upcoming kafs-client package correctly.  The problem is that the kafs-client package can't simply declare /afs as a directory because then package upgrading breaks as dnf doesn't seem to be able to upgrade a package to a newer version if there's a direct directory spec.

Instead, various afs clients (including OpenAFS, for example) try to create the /afs directory from a post install script with mkdir - which is really the wrong solution.

I've included a patch to make the change.

Comment 1 David Howells 2019-06-13 12:59:51 UTC
Created attachment 1580267 [details]
Patch to add /afs to a filesystem subpackage

Here's an alternative patch that creates a subpackage (filesystem-afs) that just adds the /afs directory.  I would prefer the initial patch.

Comment 2 Ondrej Vasik 2019-06-20 13:57:46 UTC
I prefer the afs subpackage ... as I don't think this is something that needs to be installed by default for all systems. AFS clients should require this subpackage. Pushed the commit and built rawhide.


Note You need to log in before you can comment on or make changes to this bug.