Bug 1720246 - HPA not working as openshift-metrics-server fails to gather pod metrics
Summary: HPA not working as openshift-metrics-server fails to gather pod metrics
Keywords:
Status: CLOSED DUPLICATE of bug 1593634
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Seth Jennings
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-13 13:32 UTC by Robert Sandu
Modified: 2019-06-18 14:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-18 13:52:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Sandu 2019-06-13 13:32:39 UTC
Description of problem: HPA fails as no pod metrics are gathered by the openshift-metrics-server.

`oc get/describe hpa <HPA>``shows cpu/memory metrics as `<unknown>`.

Attaches outputs:

- oc get hpa --all-namespaces
- oc plugin sos -n openshift-metrics-server

Version-Release number of selected component (if applicable): v3.11.104

How reproducible: issue shows up frequently, and seems to affect all namespaces randomly.

Steps to Reproduce:
1.N/A

Actual results: metrics-server is apparently failing to gather pod metrics.


Expected results: pod metrics to be collected and HPA to work.


Additional info:

- Similar issue to the one described in https://bugzilla.redhat.com/show_bug.cgi?id=1690034
- The issue is having an impact on the production environment.

Comment 12 Seth Jennings 2019-06-18 13:52:44 UTC

*** This bug has been marked as a duplicate of bug 1593634 ***


Note You need to log in before you can comment on or make changes to this bug.