Bug 172028 - sort breaks autofs
sort breaks autofs
Status: CLOSED DUPLICATE of bug 172111
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-10-29 10:14 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 11:39:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-10-29 10:14:26 EDT
Description of problem:
Latest sort breaks autofs.  /var/log messages contains:

Oct 29 09:59:08 ontap automount[19246]: >> sort: open failed: +0: No such file
or directory
Oct 29 09:59:08 ontap automount[19246]: lookup(program): lookup for barrel failed
Oct 29 09:59:08 ontap automount[19246]: failed to mount /net/barrel



Version-Release number of selected component (if applicable):
coreutils-5.92-1

How reproducible:
100%

Steps to Reproduce:
1.cd /net/barrel
2.
3.
  
Actual results:


Expected results:


Additional info:
Breakage occurs on both i386 and x86_64.

Reverting to coreutils-5.2.1-56 fixes the problem.
Comment 1 John Ellson 2005-10-30 11:17:48 EST
See also bug# 166328 "Thunderbird won't start after update" 
I theorize that that bug is also caused by the new sort.
Comment 2 Alexandre Oliva 2005-10-31 11:39:25 EST
coreutils is not to blame, it's just following the POSIX standard.  Read
/usr/share/doc/coreutils-5.92/NEWS, search for `sort' in there.

*** This bug has been marked as a duplicate of 172111 ***

Note You need to log in before you can comment on or make changes to this bug.