Bug 172032 - Modules required for USB stick not loaded during boot
Summary: Modules required for USB stick not loaded during boot
Status: CLOSED DUPLICATE of bug 172031
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-29 16:01 UTC by wdef200
Modified: 2014-03-17 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-29 16:06:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wdef200 2005-10-29 16:01:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Samsung Mighty Drive 500MB usb stick cannot be mounted after plugging in because
device /dev/sda1 does not exist.  On investigation, the required modules are not being loaded during boot.  This is fixed after boot by either running System Tools --> Hardware Browser, or manually loading scsi_mod, sd_mod and usb-storage.

More permanent workaround is to edit /etc/rc.sysinit to load the required modules during boot.  Usb stick connected during boot can then be automounted and icon will be present on desktop as expected.

Suggests something wrong in /etc/rc.sysinit?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add usual line to /etc/fstab to allow mounting of usb stick
2. Plug in usb stick
3. Try to mount
  

Actual Results:  Mount fails.  /dev/sda1 does not exist.

Expected Results:  vfat filesystem on /dev/sda1 should get mounted on mountpoint.

Additional info:

My apologies if this duplicates another report - I could not find one quite the same however there are complaints that are conceivably related -  see

https://bugzilla.redhat.com/bugzilla/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=NEEDINFO&bug_status=REOPENED&field0-0-0=product&type0-0-0=substring&value0-0-0=Fedora&field0-0-1=component&type0-0-1=substring&value0-0-1=Fedora&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=Fedora&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=Fedora&field1-0-0=product&type1-0-0=substring&value1-0-0=usb&field1-0-1=component&type1-0-1=substring&value1-0-1=usb&field1-0-2=short_desc&type1-0-2=substring&value1-0-2=usb&field1-0-3=status_whiteboard&type1-0-3=substring&value1-0-3=usb&field2-0-0=product&type2-0-0=substring&value2-0-0=device&field2-0-1=component&type2-0-1=substring&value2-0-1=device&field2-0-2=short_desc&type2-0-2=substring&value2-0-2=device&field2-0-3=status_whiteboard&type2-0-3=substring&value2-0-3=device

Inspiration for the workaround came from

https://www.redhat.com/archives/fedora-list/2005-October/msg00724.html

which is related?

Comment 1 wdef200 2005-10-29 16:06:08 UTC

*** This bug has been marked as a duplicate of 172031 ***


Note You need to log in before you can comment on or make changes to this bug.