Bug 1720483 - LibreOffice Writer: unable to open hybrid PDFs if "PDF/A-1a" was selected in export dialog
Summary: LibreOffice Writer: unable to open hybrid PDFs if "PDF/A-1a" was selected in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-14 06:48 UTC by Felix Schwarz
Modified: 2019-06-18 18:14 UTC (History)
4 users (show)

Fixed In Version: libreoffice-6.2.4.2-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-18 18:14:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
test file which can be used to reproduce the bug easily (27.02 KB, application/pdf)
2019-06-14 06:48 UTC, Felix Schwarz
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Document Foundation 123993 0 None None None 2019-06-14 09:18:51 UTC

Description Felix Schwarz 2019-06-14 06:48:19 UTC
Created attachment 1580550 [details]
test file which can be used to reproduce the bug easily

Somehow LibreOffice Writer does not export hybrid PDFs correctly when PDF/A-1a was selected (or it does not open them correctly).

Steps to Reproduce:
1. create a document in LibreOffice Writer
2. File -> Export as... -> Export as PDF (roughly translated from German)
3. check "Hybrid-PDF" AND "PDF/A-1a (ISO 19005-1)"
4. export file
5. open created PDF file in writer
(I'll attach a test file so you can skip steps 1-4.)

Actual Results:
Writer displays the PDF as text:
> %PDF-1.4
> %äüöß
> 2 0 obj
> <</Length 3 0 R/Filter/FlateDecode>>
> stream
...

Expected Results:
Actual LibreOffice document can be edited with all previous formatting.

Reproducible: Always

Version: libreoffice-writer-6.2.4.2-2.fc30.x86_64


Additional Info:
This seems to be a Fedora-specific bug.

I installed the LibreOffice flatpak from Flathub (version 6.2.4.2, Build-ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64) and that version works as expected.

This bug also occurred on Fedora 29 with LibreOffice 6.1.5.2. Initially I assumed this was a problem in LibreOffice 6.1 (hence my upstream bug report https://bugs.documentfoundation.org/show_bug.cgi?id=123993) but even Fedora's LibreOffice 6.2 contains the bug.

Comment 1 Felix Schwarz 2019-06-14 09:22:02 UTC
Just to clarify: I resolved the upstream bug as WORKSFORME after I noticed that upstream's flatpak version worked fine.

However the Fedora version still does not work (even after the version upgrade to 6.2) so I think something is wrong specifically with the Fedora builds (maybe a bug in some linked library?).

Comment 2 Caolan McNamara 2019-06-14 09:23:31 UTC
hmm, what is the output of...

rpm -q libreoffice-pdfimport

?

Comment 3 Felix Schwarz 2019-06-14 09:33:47 UTC
spot on - libreoffice-pdfimport was not installed.

After the installation everything works. I'm curious if this is something which should be fixed in LibreOffice (e.g. rejecting to open PDF files if pdfimport is not installed)?

Comment 4 Caolan McNamara 2019-06-14 09:35:56 UTC
I wonder if we should just accept that writer, impress etc should all depend on that pdfimport rpm due to the hybrid feature. That's probably the simplest thing to do and would mean this problem doesn't arise.

Comment 5 Caolan McNamara 2019-06-14 09:38:41 UTC
Lets do that in >= libreoffice-6.2.4.2-4.fc30 so this can't happen again

Comment 6 Felix Schwarz 2019-06-14 09:57:51 UTC
(In reply to Caolan McNamara from comment #4)
> I wonder if we should just accept that writer, impress etc should all depend
> on that pdfimport rpm due to the hybrid feature. That's probably the
> simplest thing to do and would mean this problem doesn't arise.

Fine with me :-)
Thank you for taking care of that.

Comment 7 Fedora Update System 2019-06-15 20:52:34 UTC
FEDORA-2019-65570a4e9e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-65570a4e9e

Comment 8 Fedora Update System 2019-06-16 00:54:30 UTC
libreoffice-6.2.4.2-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-65570a4e9e

Comment 9 Fedora Update System 2019-06-18 18:14:36 UTC
libreoffice-6.2.4.2-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.