Bug 172062 - RFE: update libgsf to 1.13.2
Summary: RFE: update libgsf to 1.13.2
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgsf   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-30 11:39 UTC by Michael Wise
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.13.3-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 09:16:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Wise 2005-10-30 11:39:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
Would it be possible to update libgsf.  I am trying to comile gnucash2. It needs libgoffice and libgoffice-0.1 needs at least libgsf-1.13.1

Version-Release number of selected component (if applicable):
libgsf-1.12.3-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:

Comment 1 Caolan McNamara 2005-11-01 09:16:12 UTC
Well the 1.13 series is technically "unstable", and I don't want to get into
supporting an unstable version. 1.12-3 was only released in september. I'm
reluctant to move to 1.13.

Comment 2 Hans de Goede 2005-11-25 13:55:58 UTC
I would like to add a me too or +1 to this ticket, I would like to update
gnumeric in extras to 1.6 which needs libgoffice-0.1.x which needs libgsf >=
1.13.2 . Please reconcider.


Comment 3 Hans de Goede 2005-11-25 13:58:33 UTC
As an alternative I might create a libgsf13 package, whot is you opinion on that?


Comment 4 Caolan McNamara 2005-11-25 14:08:57 UTC
I'm not in favour of putting in a 1.13 under-development package until it's 1.14
as I don't need the pain of api changes right now for libwpd->OOo and whatever
else is lurking in the grass. A libgsf13 package sounds good

Comment 5 Hans de Goede 2005-11-26 22:41:37 UTC
In the meantime I've made a special libgsf113 package for extras which can be
installed next to the core libgsf without any problems. See bug 174266 for the
extras review. I've also created a goffice package for extras, see Bug 174267
for the review.

Comment 6 Caolan McNamara 2005-12-02 20:15:18 UTC
hmm, one of my more gung-ho co-workers has upgraded it anyway :-)

Comment 7 Hans de Goede 2005-12-05 12:57:35 UTC
Hmm,

Could you add an Obsoletes libgsf113(-devel) to it so that it get rids of
libgsf113, this doesn't conflict but ldd on something linked to libgsf might get
the extra versions as that adds /usr/lib(64)/libgsf-1.13/lib to the ldpath.

I'll update goffice and gnumeric to build against the new in core package (not
set a special PKGCONFIG path and change requires).

Thanks,

Hans


Comment 8 Caolan McNamara 2005-12-05 13:06:21 UTC
ok, done.


Note You need to log in before you can comment on or make changes to this bug.