Bug 1720668 - Rebuild RHEL8 with Appstream kickstart repo fails to install redhat-lsb-core and wget packages
Summary: Rebuild RHEL8 with Appstream kickstart repo fails to install redhat-lsb-core ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high with 3 votes vote
Target Milestone: 6.6.0
Assignee: Jonathon Turel
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-14 13:42 UTC by Ahmed Eladawy
Modified: 2020-06-23 12:50 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
When you rebuild a RHEL 8 host, the Appstream kickstart repository is missing from the host, therefore some basic packages cannot be installed. As a workaround, clone the original Kickstart template and add the following string after line 70. Then, save this template and use it for provisioning RHEL 8 hosts. ---- <%="repo --name Red_Hat_Enterprise_Linux_8_for_x86_64_-_AppStream_Kickstart_x86_64_8 --baseurl http://satellite.example.com/pulp/repos/Your_Organization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/appstream/kickstart/ " %> ----
Clone Of:
Environment:
Last Closed: 2019-09-09 15:38:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Missing_packages (16.73 KB, image/png)
2019-08-20 14:05 UTC, Ahmed Eladawy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 27570 0 Normal Rejected Rebuild RHEL8 with Appstream kickstart repo fails to install redhat-lsb-core and wget packages 2021-02-08 18:49:11 UTC
Red Hat Bugzilla 1746333 0 unspecified CLOSED Specify CV and AK requirements for provisioning RHEL8 hosts 2021-02-22 00:41:40 UTC

Description Ahmed Eladawy 2019-06-14 13:42:00 UTC
Description of problem:

When rebuild RHEL8 again after the first build , it fails to install redhat-lsb-core and wget packages.

Version-Release number of selected component (if applicable):
Satellite 6.5

How reproducible:
100%

Steps to Reproduce:
1. Add the following repositories to the used content-view for provisioning and publish/promote it
Red Hat Enterprise Linux 8 for x86_64 - AppStream Kickstart x86_64 8
Red Hat Enterprise Linux 8 for x86_64 - AppStream RPMs x86_64 8
Red Hat Enterprise Linux 8 for x86_64 - BaseOS RPMs x86_64 8
Red Hat Satellite Tools 6.5 for RHEL 8 x86_64 RPMs x86_64

2.Build the RHEL8 machine.
This will add the following line to the provisioning template:
repo --name Red_Hat_Enterprise_Linux_8_for_x86_64_-_AppStream_Kickstart_x86_64_8 --baseurl http://[SAT-NAME]/pulp/repos/Dorganization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/appstream/kickstart/ 

3. After the rebuild is finished, try to rebuild the machine again.

Actual results:
1. The following line is now added to the provisioning template :
repo --name Red_Hat_Enterprise_Linux_8_for_x86_64_-_AppStream_Kickstart_x86_64_8 --baseurl http://[SAT-NAME]/pulp/repos/Dorganization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/appstream/kickstart/ 
2. Fails on redhat-lsb-core and wget packages installation

Expected results:
Not to fail

Additional info:

Workaround has been applied by the customer by cloning the original template and hard-coded the missing line on it and use it instead of the original template.

Comment 3 Ivan Necas 2019-07-25 08:00:01 UTC
@Ahmed: What was the missing line you've mentioned in the workaround - it's not clear for me after reading the description

Comment 4 Ahmed Eladawy 2019-07-25 08:46:19 UTC
@Ivan ,

I mean after rebuilding the machine again the appstream kickstart repository will not be included on the provisioning template and this will stop the provisioning because some packages will not be available like wget .

So in the first try , when preview the provisioning templates , you can find the following :

url --url http://aeladawy-sat65.sysmgmt.lan/pulp/repos/Dorganization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/baseos/kickstart/

repo --name Red_Hat_Enterprise_Linux_8_for_x86_64_-_AppStream_Kickstart_x86_64_8 --baseurl http://aeladawy-sat65.sysmgmt.lan/pulp/repos/Dorganization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/appstream/kickstart/ 


but when rebuild the machine again after the first try , only the following line is on the provisioning template :

url --url http://aeladawy-sat65.sysmgmt.lan/pulp/repos/Dorganization/Library/RHEL8-Provisioning/content/dist/rhel8/8/x86_64/baseos/kickstart/

Comment 5 Marek Hulan 2019-08-09 07:53:32 UTC
Created redmine issue https://projects.theforeman.org/issues/27570 from this bug

Comment 6 Marek Hulan 2019-08-09 08:50:48 UTC
The additional repo is added from Katello - see https://github.com/Katello/katello/commit/a090aae2b582b84b8038ec562dec1186dae5d744

Comment 7 Ahmed Eladawy 2019-08-15 09:32:42 UTC
After the build is finished successfully , if you try to build the machine again , the AppStream kickstart repository will not be created by the provisioning template .

So, the additional media is not available anymore after finishing the provisioning the first time.


<% @additional_media.each do |medium| -%>
repo --name <%= medium[:name] %> --baseurl <%= medium[:url] %> <%= medium[:install] ? ' --install' : '' %>

Comment 11 Ahmed Eladawy 2019-08-20 14:05:36 UTC
Created attachment 1606105 [details]
Missing_packages

Comment 27 Lukas Zapletal 2019-09-03 08:08:10 UTC
I think it is worth issuing warning in these cases: https://bugzilla.redhat.com/show_bug.cgi?id=1748232


Note You need to log in before you can comment on or make changes to this bug.