Bug 1720753 - Advanced Search Filter doesn't work when more than 1 different conditions[AND|OR|NOT] are used
Summary: Advanced Search Filter doesn't work when more than 1 different conditions[AND...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.6
Assignee: Harpreet Kataria
QA Contact: Angelina Nikiforova
Red Hat CloudForms Documentation
URL:
Whiteboard:
: 1718895 (view as bug list)
Depends On: 1660460
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-14 20:03 UTC by Satoe Imaishi
Modified: 2019-07-02 04:33 UTC (History)
11 users (show)

Fixed In Version: 5.10.6.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1660460
Environment:
Last Closed: 2019-07-02 04:33:28 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1644 None None None 2019-07-02 04:33:36 UTC

Comment 2 CFME Bot 2019-06-14 20:05:31 UTC
New commits detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/581d68f438469225b9d95426ce15d304db7f3d50
commit 581d68f438469225b9d95426ce15d304db7f3d50
Author:     Keenan Brock <keenan@thebrocks.net>
AuthorDate: Thu May  2 11:54:38 2019 -0400
Commit:     Keenan Brock <keenan@thebrocks.net>
CommitDate: Thu May  2 11:54:38 2019 -0400

    Merge pull request #18709 from d-m-u/fixing_arel_node_grouping_for_and

    Group AND expressions properly to account for nesting

    (cherry picked from commit 5c506fda3951e5efb724385aca145f5877ae6525)

    https://bugzilla.redhat.com/show_bug.cgi?id=1720753

 lib/miq_expression.rb | 2 +-
 spec/lib/miq_expression_spec.rb | 34 +-
 2 files changed, 27 insertions(+), 9 deletions(-)


https://github.com/ManageIQ/manageiq/commit/8e31216c10fe109043267b82e0903ff0a1f2cb94
commit 8e31216c10fe109043267b82e0903ff0a1f2cb94
Author:     Joe Rafaniello <jrafanie@users.noreply.github.com>
AuthorDate: Fri Jun 14 10:51:10 2019 -0400
Commit:     Joe Rafaniello <jrafanie@users.noreply.github.com>
CommitDate: Fri Jun 14 10:51:10 2019 -0400

    Merge pull request #18867 from h-kataria/mixed_operator_conditions_fix

    assign value to a variable and return at the end.

    (cherry picked from commit 0466cd65679de80ca08eda54d6cccb2f6b0d49c9)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1720753

 lib/miq_expression/subst_mixin.rb | 14 +-
 spec/lib/miq_expression/subst_mixin_spec.rb | 34 +
 2 files changed, 43 insertions(+), 5 deletions(-)

Comment 3 Angelina Nikiforova 2019-06-25 10:37:19 UTC
Fixed and verified in 5.10.6.1.20190621202107_58f5bbc

Comment 4 Harpreet Kataria 2019-06-25 16:17:36 UTC
*** Bug 1718895 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2019-07-02 04:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1644


Note You need to log in before you can comment on or make changes to this bug.