Bug 172079 - xen kernel panic
xen kernel panic
Status: CLOSED DUPLICATE of bug 172406
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 17:17 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 13:09:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-30 17:17:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
Booting Xen gives me the following kernel panic:

(XEN) *****
(XEN) Panic on CPU0:
(XEN) Domain 0 allocation is too small for kernel image.
(XEN) *****
(XEN) 
(XEN) Reboot in five seconds...

Versions:
 kernel-xenU.i686                         2.6.13-1.1532_FC4
 xen.i386                                 3.0-0.20050912.fc4

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-11-15 17:28:17 EST
This is still broken, and fc5t1 is frozen now.
Please could you tell me what the problem?
Comment 2 Need Real Name 2005-12-01 10:09:10 EST
Lack of interest. Do you want this closed?
Comment 3 Stephen Tweedie 2006-01-18 13:03:35 EST
There has been a significant rebasing of the kernel and HV images for fc5t2. 
Can you still reproduce the problem?

If so, then this sounds like a mismatch between the memory calculations in the
HV/bootloader and the kernel.  The full Xen logs would be really useful in
tracking this down; is it possible for you to capture that to a serial console?
 That, in conjunction with the normal non-xen boot logs, should let us examine
the memory maps being computed in both cases to see if there's a mismatch somewhere.

You _may_ be able to work around this by adding the "dom0_mem=...M" option to
the xen hypervisor line ("kernel=xen...") in /etc/grub.conf.  If you assign
(say) only half your physical memory to dom0 on boot, does that work?
Comment 4 Stephen Tweedie 2006-01-18 13:09:16 EST
There are a number of other reports of this in bug 172406: I'll close this one
as a dup to keep the majority of the reports in one place.  Please followup in
the other bug report.



*** This bug has been marked as a duplicate of 172406 ***

Note You need to log in before you can comment on or make changes to this bug.