Bug 1720948 - Relink `/lib64/libmagic.so.1' with `/lib64/libpthread.so.0' for IFUNC symbol `vfork'
Summary: Relink `/lib64/libmagic.so.1' with `/lib64/libpthread.so.0' for IFUNC symbol ...
Keywords:
Status: CLOSED DUPLICATE of bug 1473680
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-16 18:58 UTC by Elliott Sales de Andrade
Modified: 2019-06-18 07:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-18 07:21:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2019-06-16 18:58:47 UTC
Description of problem:
Building a new git-annex, whenever the tests run it, it prints out:
git-annex: Relink `/lib64/libmagic.so.1' with `/lib64/libpthread.so.0' for IFUNC symbol `vfork'


Version-Release number of selected component (if applicable):
5.37-1.fc31


How reproducible:
Link something with libmagic.so.1 and then run it.

Comment 1 Kamil Dudka 2019-06-17 12:56:31 UTC
(In reply to Elliott Sales de Andrade from comment #0)
> How reproducible:
> Link something with libmagic.so.1 and then run it.

/usr/bin/file is linked with libmagic.so.1 and it works just fine.

Comment 2 Elliott Sales de Andrade 2019-06-17 22:08:39 UTC
Yes, strange. Looking at other similar bugs (bug 1473680), I don't know if this might be a toolchain issue elsewhere.

Comment 3 Kamil Dudka 2019-06-18 07:21:16 UTC
Thank you for digging it up!  It is not clear what libmagic could do better.  I am closing this as a duplicate of bug #1473680.

*** This bug has been marked as a duplicate of bug 1473680 ***


Note You need to log in before you can comment on or make changes to this bug.