Bug 172096 - crontab task fail to run withour restart crond
crontab task fail to run withour restart crond
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vixie-cron (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 08:19 EST by Leon Li
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 11:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Li 2005-10-31 08:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
I add a new cron task as following:

13 21 * * * ps ax > /tmp/ps.log

The task do not run and there is no notification email.

But after I restart crond service: 

service crond restart

The cron task runs well.


Version-Release number of selected component (if applicable):
vixie-cron-4.1-20_EL

How reproducible:
Always

Steps to Reproduce:
1. add a new crontab task  crontab -e : 14 17 * * * ps ax > /tmp/rootps.log
2.
3.
  

Actual Results:  The task failed to run without restart crond

Additional info:
Comment 1 Jason Vas Dias 2005-10-31 11:07:47 EST
Actually, I think you'll find that if you wait at least 2 minutes after making
the update, it will take effect without crond restart.
Currently, crond works by loading any updates when the minute changes ; 
e.g. at 12:00:00, 12:01:00, and then scheduling the jobs to be run at
successive minutes, so if a job is loaded at 12:00, it will not be run
until 12:01:00 .
So if your '14 17 * * *' job was updated between 17:14:00 and 17:15:59, 
it would only be loaded at 17:15:00, and would not be run until 17:15 the 
next day .
I am looking at changing this with enhancements to vixie-cron-4.1, which by
default behaves this way, but as the updates always do take effect, this is
not a bug. If you are finding that an update does not take effect within two
minutes, which I cannot reproduce, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.