Bug 1721019 - [OSP15- MIGRATION ]missing Python3 support for the migration in
Summary: [OSP15- MIGRATION ]missing Python3 support for the migration in
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Jakub Libosvar
QA Contact: Roman Safronov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-17 07:17 UTC by Eran Kuris
Modified: 2020-03-05 11:54 UTC (History)
9 users (show)

Fixed In Version: python-networking-ovn-6.0.1-0.20190813160454.89e84c9.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-05 11:53:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1839834 0 None None None 2019-08-12 12:42:20 UTC
OpenStack gerrit 677935 0 None MERGED migration: Use python3 packages when needed 2020-03-03 21:08:50 UTC
Red Hat Product Errata RHBA-2020:0709 0 None None None 2020-03-05 11:54:19 UTC

Description Eran Kuris 2019-06-17 07:17:21 UTC
Description of problem:

OVN migration job is failing with error:
TASK [Install python virtualenv] ***********************************************
task path: /home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-vxlan-ml2ovs-to-ovn-migration/infrared/plugins/tripleo-ovn-migration/migration/infrared/tripleo-ovn-migration/main.yml:6
Saturday 15 June 2019  21:50:24 +0000 (0:00:03.216)       0:00:03.420 ********* 
fatal: [undercloud-0]: FAILED! => {
    "changed": false, 
    "failures": [
        "No package python-virtualenv available."
    ], 
    "rc": 1, 
    "results": []
}

MSG:

Failed to install some of the specified packages

	to retry, use: --limit @/home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-vxlan-ml2ovs-to-ovn-migration/infrared/plugins/tripleo-ovn-migration/migration/infrared/tripleo-ovn-migration/main.retry

PLAY RECAP *********************************************************************
undercloud-0               : ok=1    changed=0    unreachable=0    failed=1   


looks like packages issue 
Version-Release number of selected component (if applicable):
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/networking-ovn/job/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-vxlan-ml2ovs-to-ovn-migration/12/console

OSP15 core_puddle: RHOS_TRUNK-15.0-RHEL-8-20190614.n.1



How reproducible:


Steps to Reproduce:
1. run migration job
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Bernard Cafarelli 2019-07-11 13:40:25 UTC
From a quick look, is the virtualenv needed? The migration tool comes from package

In all cases, python-networking-ovn-migration-tool will likely need an update to get the python3-* variant (infrared already has some examples with conditions on os version)
Same for virtualenv if it is needed

I also saw a few *docker* occurrences, some are just in task names or paths, but some variables will need a conditional, like DockerOvnControllerImage->ContainerOvnControllerImage

Comment 14 errata-xmlrpc 2020-03-05 11:53:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0709


Note You need to log in before you can comment on or make changes to this bug.