Bug 172108 - perl-DB_File not included, functionality for Spamassassin reduced
perl-DB_File not included, functionality for Spamassassin reduced
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: spamassassin (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 10:58 EST by Ed Asbury
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 11:30:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Asbury 2005-10-31 10:58:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
The Perl-DB_File module is not available on any of the channels.  The module is needed for the Bayes functionality to work in Spamassassin.  This omission reduces the effectiveness of Spamassassin significantly and requires extra work on the part of sys admins that shouldn't be required of an "Enterprise" operating system.  Since Spamassassin is part of the base RHEL4 package, all of the components to make it work should also be included.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to use Bayesian functionality in Spamassassin
2.
3.
  

Actual Results:  Fails with error message "debug: bayes: DB_File module not installed, cannot use Bayes" because the perl-DB_File module is not available and installed.

Additional info:
Comment 1 Warren Togami 2005-10-31 11:20:39 EST
[root@master ~]# rpm -q perl
perl-5.8.5-16.RHEL4
[root@master ~]# rpm -ql perl |grep DB_File
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/DB_File.pm
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/auto/DB_File
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/auto/DB_File/DB_File.so
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/auto/DB_File/autosplit.ix
/usr/share/man/man3/DB_File.3pm.gz

Works fine on my RHEL4 and DB_File is definitely provided by the main perl
package.  Did you install anything manually by chance?
Comment 2 Ed Asbury 2005-10-31 11:23:43 EST
No, the server was upgraded from RHEL3 to RHEL4 however.
Comment 3 Ed Asbury 2005-10-31 11:30:38 EST
Sorry, should have checked this beforehand, must be a spamassassin config error.

Note You need to log in before you can comment on or make changes to this bug.