Bug 1721091 - yum doesn't read config file via http any more
Summary: yum doesn't read config file via http any more
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Marek Blaha
QA Contact: Jan Blazek
URL:
Whiteboard:
: 1774126 (view as bug list)
Depends On: 1681084
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-17 10:47 UTC by Karel Srot
Modified: 2020-04-28 16:48 UTC (History)
6 users (show)

Fixed In Version: dnf-4.2.17-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:47:49 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:48:03 UTC

Description Karel Srot 2019-06-17 10:47:10 UTC
Description of problem:

# yum -c http://localhost/my-yum-config --disableplugin=rhnplugin install test-aaa'
Config error: Config file "http://localhost/my-yum-config" does not exist


Version-Release number of selected component (if applicable):
dnf-4.2.7-1.el8.noarch
libdnf-0.35.1-1.el8.x86_64
librepo-1.10.3-1.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. see above

Actual results:
config file specified with http:// URL is not used

Expected results:
config file specified with http:// URL is used


This is a regression, it was working fine with
dnf-4.2.6-1.el8.noarch
libdnf-0.33.0-1.el8.x86_64
librepo-1.10.1-1.el8.x86_64

Comment 2 Karel Srot 2019-06-17 11:00:54 UTC
FYI, neither HTTPS works.
Is there a list of supported protocols?

Comment 10 Daniel Mach 2019-09-18 12:19:16 UTC
This bug is not a regression within RHEL 8, but a different behavior to RHEL 7.
Removing Regression keyword.

Comment 14 jcastran 2019-11-19 16:35:26 UTC
*** Bug 1774126 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2020-04-28 16:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.