Bug 1721531 - [ceph-ansible] - replace ntpd with chronyd
Summary: [ceph-ansible] - replace ntpd with chronyd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Ameena Suhani S H
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-18 13:40 UTC by Vasishta
Modified: 2020-01-31 12:46 UTC (History)
7 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc11.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
File contains playbook log (5.93 MB, text/plain)
2019-06-18 13:42 UTC, Vasishta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4105 0 None closed ceph-infra: make chronyd default NTP daemon (bp #4089) 2021-02-20 05:39:10 UTC
Github ceph ceph-ansible pull 4233 0 None closed ceph-infra: update handler with daemon variable (bp #4223) 2021-02-20 05:39:10 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:41 UTC

Description Vasishta 2019-06-18 13:40:54 UTC
Description of problem:
In RHEL 8 ntpd seems to be unavailable and chronyd seems to be available by default. 
It would be more appropriate if we can replace ntpd with chronyd in ceph-ansible tasks.


How reproducible:
Always

Steps to Reproduce:
1. initialize a cluster and check availability of a ntp daemon.

Actual results:
no ntp daemons are active

Expected results:
there should be a ntp daemon active

Comment 1 Vasishta 2019-06-18 13:42:38 UTC
Created attachment 1581712 [details]
File contains playbook log

Comment 6 Giridhar Ramaraju 2019-08-05 13:11:38 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 7 Giridhar Ramaraju 2019-08-05 13:12:35 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 8 Ameena Suhani S H 2019-12-20 17:25:40 UTC
Verified using
ceph version 14.2.4-85.el8cp 
ceph-ansible-4.0.6-1.el8cp.noarch
ansible-2.8.7-1.el8ae.noarch

Moving to "VERIFIED" state.

Comment 10 errata-xmlrpc 2020-01-31 12:46:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.