Bug 1721572 - Kube-scheduler-operator: backport a test to ensure no regression
Summary: Kube-scheduler-operator: backport a test to ensure no regression
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: ravig
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-18 15:03 UTC by ravig
Modified: 2019-06-19 10:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-19 10:49:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ravig 2019-06-18 15:03:15 UTC
Description of problem:

Backport test framework to ensure there is no regression to 4.1.z branch

Comment 1 ravig 2019-06-18 15:06:42 UTC
We need this patch to go in to close the bz:

https://github.com/openshift/cluster-kube-scheduler-operator/pull/146

Comment 4 Xingxing Xia 2019-06-19 10:49:11 UTC
Tested it in 4.1.0-0.nightly-2019-06-18-235904 env BTW:
$ git clone git@github.com:openshift/cluster-kube-scheduler-operator.git
$ export KUBECONFIG=/home/xxia/all/env/my-0619.cfg
$ git checkout -b release-4.1 upstream/release-4.1
$ go test                                                                                                        
found operator deployment                                                                                                                                            
PASS                                                                                                                                                                  
ok      github.com/openshift/cluster-kube-scheduler-operator/test/e2e   5.972s

Because it is not a functional bug. I'd like to close as NOTA.


Note You need to log in before you can comment on or make changes to this bug.