Bug 1721673 - after the undercloud installation finishes, the command line is left in a broken state
Summary: after the undercloud installation finishes, the command line is left in a bro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Alex Schultz
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-18 20:38 UTC by Alex Schultz
Modified: 2019-09-26 10:52 UTC (History)
3 users (show)

Fixed In Version: python-tripleoclient-11.4.1-0.20190628190406.7d41f81.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1833302 0 None None None 2019-06-18 20:58:48 UTC
OpenStack gerrit 668174 0 None None None 2019-06-28 13:23:39 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:36 UTC

Description Alex Schultz 2019-06-18 20:38:39 UTC
Description of problem:
After installing the undercloud, the user's shell is left in a broken state such that a user needs to run a reset to be able to see what's being typed. This is likely caused by podman or ansible eating escape sequences during the installation.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Run undercloud install to completion
2. attempt to type something on the command line
3.

Actual results:
The user's input is not shown and line breaks are ignored

Expected results:
Normal user input should appear

Additional info:

Comment 1 Alex Schultz 2019-06-18 20:39:54 UTC
A workaround is to run 'reset' after the installation.

Comment 5 Sasha Smolyak 2019-07-21 12:08:26 UTC
Fixed. Verified

Comment 9 errata-xmlrpc 2019-09-21 11:23:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.