Bug 1721685 - node-ca pod is missing resource requests
Summary: node-ca pod is missing resource requests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-18 21:28 UTC by Derek Carr
Modified: 2019-07-31 02:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: add resources request to node-ca pod Reason: the pod needs minimal guarantees about the amount of CPU and memory it will get Result: node-ca pod has resources request
Clone Of:
Environment:
Last Closed: 2019-07-31 02:44:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1866 None None None 2019-07-31 02:45:02 UTC

Description Derek Carr 2019-06-18 21:28:06 UTC
Description of problem:
the image registry operator that deploys the node ca pod is not including resource requests.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 wewang 2019-07-25 07:53:47 UTC
verified in 4.2.0-0.nightly-2019-07-23-002801

$ oc describe pod node-ca-48srg  -n openshift-image-registry

    Restart Count:  1
    Requests:
      cpu:        10m
      memory:     10Mi
    Environment:  <none>
    Mounts:

Comment 5 wewang 2019-07-25 07:54:51 UTC
and will check it in 4.1.x

Comment 6 wewang 2019-07-25 07:58:16 UTC
Verified in 
4.1.0-0.nightly-2019-07-24-213555

$oc describe pod node-ca-57z9f -n openshift-image-registry
    Requests:
      cpu:        10m
      memory:     10Mi
    Environment:  <none>
    Mounts:

Comment 8 errata-xmlrpc 2019-07-31 02:44:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1866


Note You need to log in before you can comment on or make changes to this bug.