Bug 1721887 - The VM power off/on from CR -> VMs tab, throws undefined method error 'state'
Summary: The VM power off/on from CR -> VMs tab, throws undefined method error 'state'
Keywords:
Status: CLOSED DUPLICATE of bug 1721888
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - GCE
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Kavita
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-19 08:32 UTC by Jitendra Yejare
Modified: 2019-06-21 14:28 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-21 14:28:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 26812 High Closed The VM power off/on from CR -> VMs tab, throws undefined method error 'state' 2019-12-19 15:41:52 UTC

Description Jitendra Yejare 2019-06-19 08:32:34 UTC
Description:
-------------------
The VM power off/on from CR -> VMs throws below error but the VM in GCE is turning on and off as expected.
Error - undefined method `state' for #Fog::Compute::Google::Server:0x005564da4bac78 Did you mean? start status

Step:
---------
1. Create/Integrate a Compute Resource of GCE in/with foreman.
2. Wait for all the VMs to be listed in VMs tab under GCE CR.
3. Click PowerOff/On button for the VM in VMs tab.

Actual Result:
----------------
The VM power off/on from CR -> VMs throws below error but the VM in GCE is turning on and off as expected.
Error - undefined method `state' for #Fog::Compute::Google::Server:0x005564da4bac78 Did you mean? start status

Expected Behavior:
--------------------
The VM Power on/off should not through any error.

Comment 3 Jitendra Yejare 2019-06-19 08:32:38 UTC
Created from redmine issue https://projects.theforeman.org/issues/26812

Comment 4 Bryan Kearney 2019-06-19 10:03:37 UTC
Upstream bug assigned to kgaikwad@redhat.com

Comment 5 Bryan Kearney 2019-06-19 10:03:38 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/26812 has been resolved.

Comment 6 Brad Buckingham 2019-06-21 14:28:02 UTC

*** This bug has been marked as a duplicate of bug 1721888 ***


Note You need to log in before you can comment on or make changes to this bug.