This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 172194 - Missing files when listing an NT4 share
Missing files when listing an NT4 share
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks: 430698
  Show dependency treegraph
 
Reported: 2005-11-01 09:22 EST by Bastien Nocera
Modified: 2008-01-29 10:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 12:27:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
linux-2.6.9-smbfs-wrong-packet-size.patch (462 bytes, patch)
2005-11-01 09:22 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-11-01 09:22:38 EST
Using smbfs on a 2.6.9-11.EL kernel, with the server being a Win2k, Win2k3,
Win9x, NT4 or Samba3, when listing a directory with a large number of files, and
some long names, some files end up missing in the listing.

From the comments in RHEL4's linux-2.6.9/fs/smbfs/request.c:
        /*
         * max parameters + max data + max setup == bufsize to make NT4 happy
         * and not abort the transfer or split into multiple responses. It also
         * makes smbfs happy as handling packets larger than the buffer size
         * is extra work.
         *
         * OS/2 is probably going to hate me for this ...
         */

So:
max data = bufsize - max parameters - max setup
which means:
mdata = req->rq_bufsize - SMB_TRANS2_MAX_PARAM - server->opt.max_xmit - 100; /*
the -100 being to make OS/2 happy, apparently */

The current code doesn't do that...
Comment 1 Bastien Nocera 2005-11-01 09:22:39 EST
Created attachment 120601 [details]
linux-2.6.9-smbfs-wrong-packet-size.patch
Comment 4 Bastien Nocera 2005-12-01 06:51:43 EST
Adding a blocker. Work will be done on the RHEL3 version.
Comment 7 Bastien Nocera 2006-05-10 10:23:40 EDT
Comment on attachment 120601 [details]
linux-2.6.9-smbfs-wrong-packet-size.patch

Patch is broken.
Comment 10 RHEL Product and Program Management 2007-05-09 07:09:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Jeff Layton 2007-06-07 11:53:50 EDT
I've not been able to reproduce this problem at all with a client running my
current peoplepage kernels. I've tried samba 3.0.25 (running on f7 and fc6), and
a win2k server. I've also tried having the script create varying amounts of
files (700, 900, 1000, and 7000). I always seem to get the correct number of
files returned.

Can you verify whether this bug is already fixed in 4.5 kernels and/or the
kernels on my peoplepage:

http://people.redhat.com/jlayton
Comment 12 RHEL Product and Program Management 2007-09-07 15:46:57 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 14 Jeff Layton 2007-12-05 12:27:58 EST
Closing this BZ since there's been no activity on it for a long time and the IT
associated with it has closed. Please reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.