Bug 17220 - TCP wrappers not built into Xinetd configuration by default
Summary: TCP wrappers not built into Xinetd configuration by default
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-03 22:15 UTC by Brian J. Conway
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-03 22:15:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian J. Conway 2000-09-03 22:15:05 UTC
Despite the message printed out at startup,
Sep  3 17:51:08 ladyluck xinetd[22847]: xinetd Version 2.1.8.9pre8 started
with 
Sep  3 17:51:08 ladyluck xinetd[22847]: libwrap 
Sep  3 17:51:08 ladyluck xinetd[22847]: options compiled in.
Sep  3 17:51:08 ladyluck xinetd[22847]: Started working: 1 available
service
Sep  3 17:51:11 ladyluck xinetd: xinetd startup succeeded

/etc/hosts.allow and deny have no effect on the processes spawned out of
xinetd by default as inetd has in the past.  This is something that should
be looked into, as none of the available documentation easily shows how to
use tcp wrappers with xinetd, and it really needs to be there.

Comment 1 Trond Eivind Glomsrxd 2000-09-03 23:01:35 UTC
The correct usage with the beta is servicename ("telnet") instead of servername
(i"n.telnetd"). This has since been changed anyway, both in our trees and in
xined itself - it now uses the old behaviour (though I admit to much preferring
the new one)


Note You need to log in before you can comment on or make changes to this bug.