Bug 1722154 - DCI-tempest environment creation failing(subnetpool not a supported extension)
Summary: DCI-tempest environment creation failing(subnetpool not a supported extension)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Chandan Kumar
QA Contact: Martin Kopec
URL:
Whiteboard:
Depends On: 1716594 1722147
Blocks: 1737759
TreeView+ depends on / blocked
 
Reported: 2019-06-19 14:37 UTC by Martin Kopec
Modified: 2019-09-26 10:52 UTC (History)
12 users (show)

Fixed In Version: openstack-tempest-20.0.0-0.20190703110412.a955095.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of: 1722147
Environment:
Last Closed: 2019-09-21 11:23:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1832566 0 None None None 2019-06-19 14:39:36 UTC
OpenStack gerrit 664962 0 None master: MERGED tempest: Fix cleanup NotImplemented error (I9ced4af40eb0c2a22e3557caded56045a397d539) 2019-07-25 11:09:30 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:51 UTC

Description Martin Kopec 2019-06-19 14:37:56 UTC
+++ This bug was initially created as a clone of Bug #1722147 +++

+++ This bug was initially created as a clone of Bug #1716594 +++

Description of problem:
DCI tempest execution failed while creating tempest environment.

While listing subnetpool , tempest setup fails. Subnetpool extension is not a supported neutron plugin in contrail
Version-Release number of selected component (if applicable):


How reproducible:
Run the DCI tempest setup creation

Steps to Reproduce:
1.
2.
3.

Actual results:

019-05-29 17:46:30 | + /usr/bin/tempest cleanup --init-saved-state
2019-05-29 17:46:38 | Traceback (most recent call last):
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 98, in take_action
2019-05-29 17:46:38 |     self.init(parsed_args)
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 126, in init
2019-05-29 17:46:38 |     self._init_state()
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 309, in _init_state
2019-05-29 17:46:38 |     svc.run()
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup_service.py", line 132, in run
2019-05-29 17:46:38 |     self.save_state()
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup_service.py", line 705, in save_state
2019-05-29 17:46:38 |     pools = self.list()
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup_service.py", line 680, in list
2019-05-29 17:46:38 |     pools = client.list_subnetpools(**self.tenant_filter)['subnetpools']
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/subnetpools_client.py", line 28, in list_subnetpools
2019-05-29 17:46:38 |     return self.list_resources(uri, **filters)
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/lib/services/network/base.py", line 34, in list_resources
2019-05-29 17:46:38 |     resp, body = self.get(req_uri)
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 294, in get
2019-05-29 17:46:38 |     return self.request('GET', url, extra_headers, headers)
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 668, in request
2019-05-29 17:46:38 |     self._error_checker(resp, resp_body)
2019-05-29 17:46:38 |   File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 842, in _error_checker
2019-05-29 17:46:38 |     message=message)
2019-05-29 17:46:38 | NotImplemented: Got NotImplemented error
2019-05-29 17:46:38 | Details: 
2019-05-29 17:46:38 | Initializing saved state.
³!@)stdout'No tests in repository'
Expected results:


Additional info:

subnetpool not  a supported extension

Comment 4 Martin Kopec 2019-08-06 08:12:48 UTC
The fix fixes the issue, however, we could say it's only partially, explanation:
* tempest cleanup doesn't raise NotImplemented error, the exception is correctly handled now and tempest cleanup continues cleaning resources properly (even if there is an extension which is not enabled) - this was the main issue here
* however, we noticed that after the fix, 'tempest cleanup --init-saved-state' returns a non-zero return code in this case, the issue with the return code is tracked here: https://bugzilla.redhat.com/show_bug.cgi?id=1737759

Considering that the main issue has been fixed, tempest cleanup deletes resources as expected (the wrong return code though), the issue with the return code is tracked and will be fixed soon, I'm moving this to VERIFIED (the package fixes also other issues and therefore I don't want to hold it because of the return code)

Comment 6 errata-xmlrpc 2019-09-21 11:23:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.