Bug 172220 - Compilation fails because of compiler profiling
Summary: Compilation fails because of compiler profiling
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libxml2   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-01 18:24 UTC by Patrice Guay
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 23:00:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Guay 2005-11-01 18:24:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
Compilation of libxml2- on RHEL U2 x86_64 (everything installed) fails with this error message:
/usr/bin/ld: .libs/xmllint: hidden symbol `__gcov_merge_single' in /usr/lib/gcc/x86_64-redhat-linux/3.4.4/libgcov.a(_gcov_merge_single.o) is referenced by DSO
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[2]: *** [xmllint] Error 1


Version-Release number of selected component (if applicable):
libxml2-2.6.16-6

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild libxml2-2.6.16-6.src.rpm


Actual Results:  Error message (see above)

Expected Results:  libxml2 should rebuild without error.

Additional info:

This behavior could be avoided if compiler profiling specific code is removed from the SPEC file. Doing a simple %configure, make, %makeinstall works.

Comment 1 Daniel Veillard 2005-11-01 23:00:26 UTC
Already done in the version for Fedora Core 5 as well as the libxml.spec.in
present in upstream CVS,

Daniel

Comment 2 Johnny Hughes 2007-01-26 09:28:06 UTC
Is it really the correct answer to have a known issue building a package that
your customers may need to rebuild for the next 5 years, and it does not build?

I would think that known non-buildable packages should be address and fixed
inside the RHEL4 release set.

Comment 3 Johnny Hughes 2007-01-26 09:41:30 UTC
This bug is also reported in the following CentOS bug:
http://bugs.centos.org/view.php?id=1649

Comment 4 Daniel Veillard 2007-01-26 10:07:41 UTC
w.r.t #2 this is already fixed internally, maybe you just didn see the update yet,

Daniel

Comment 5 Eric Moret 2007-01-26 19:22:52 UTC
Is the ftp site the place updates should be pushed? As of this writting, I 
still don't see a libxml2 file in there.

ftp://ftp.redhat.com/pub/redhat/linux/updates/enterprise/4AS/en/os/SRPMS

Comment 6 Daniel Veillard 2007-01-27 10:30:26 UTC
It is not out yet ! Just desactivate compiler profiling in the spec file
it's trivial and that's what the Fedora and upstream packages have been doing
for 2 years now, it's not like some secret magic patch is missing !
If  doing that edit scares you, I suggest you simply don't rebuild the RPM
or rebuild the Fedora source RPM, or the associated source RPMs found in
ftp://xmlsoft.org/xml/

Daniel

Comment 7 Johnny Hughes 2007-01-27 11:09:11 UTC
That is not the point ... I know how to edit spec files (since I build and
maintain CentOS-4).

However, I don't add NON-Trademark/Logo (technical) items to RHEL packages. 
This needs to fixed in the Enterprise Linux codebase ... it is broken.


Note You need to log in before you can comment on or make changes to this bug.