Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1722214 - openshift-cluster-samples-operator state is degraded
Summary: openshift-cluster-samples-operator state is degraded
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 4.2.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1722183
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-19 17:23 UTC by Gabe Montero
Modified: 2019-10-16 06:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1722183
Environment:
Last Closed: 2019-10-16 06:32:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:32:31 UTC

Comment 1 Gabe Montero 2019-06-19 17:29:31 UTC
PR https://github.com/openshift/cluster-samples-operator/pull/153 is up on master/4.2 branch

Comment 2 Gabe Montero 2019-06-20 13:37:18 UTC
PR has merged

for QE - this is a classic race condition bug based on multiple secret events coming in during startup.  As this is the first reported instance of the race after all these months, I suspect
the timing needed to reproduce is difficult and/or env centric.

Some basic regression testing is sufficient IMO.

Comment 3 XiuJuan Wang 2019-06-25 11:47:13 UTC
Don't met the bug issue.
Do regression test following https://polarion.engineering.redhat.com/polarion/#/project/OSE/testrun?id=OS-20190625-0920.
No issue found.
Test with 4.2.0-0.nightly-2019-06-25-003324 payload.

Comment 4 errata-xmlrpc 2019-10-16 06:32:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.