Bug 1722231 - [GSS] OCS/CNS uninstall fails to remove /var/lib/glusterd, /etc/glusterfs, and /var/lib/heketi from nodes
Summary: [GSS] OCS/CNS uninstall fails to remove /var/lib/glusterd, /etc/glusterfs, an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Joseph Callen
QA Contact: Ashmitha Ambastha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-19 18:17 UTC by Anton Mark
Modified: 2019-07-23 19:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 19:56:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1753 0 None None None 2019-07-23 19:56:33 UTC

Description Anton Mark 2019-06-19 18:17:01 UTC
Description of problem:
[GSS] OCS/CNS uninstall fails to remove /var/lib/glusterd, /etc/glusterfs, and /var/lib/heketi from nodes


Version-Release number of the following components:



How reproducible:
Always.


Steps to Reproduce:
1. Install OCS with playbook (../openshift-ansible/playbooks/openshift-glusterfs/config.yml)
2. Uninstall OCS with playbook (../openshift-ansible/playbooks/openshift-glusterfs/uninstall.yml)
3. Check host nodes and above listed directories will still exist and have data in them.

Actual results:
Directories /var/lib/glusterd, /etc/glusterfs, and /var/lib/heketi still exist and have data in them.

Expected results:
Directories /var/lib/glusterd, /etc/glusterfs, and /var/lib/heketi should be deleted.

Additional info:
Upstream PR to resolve the issue I submitted. https://github.com/openshift/openshift-ansible/pull/11683

Comment 1 Joseph Callen 2019-06-20 13:05:33 UTC
PR: https://github.com/openshift/openshift-ansible/pull/11683
openshift-ansible-3.11.119-1

Comment 7 errata-xmlrpc 2019-07-23 19:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1753


Note You need to log in before you can comment on or make changes to this bug.