Bug 1722526 - must-gather loses metrics data collection
Summary: must-gather loses metrics data collection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.z
Assignee: David Eads
QA Contact: zhou ying
URL:
Whiteboard: 4.1.4
Depends On: 1722523
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-20 14:47 UTC by David Eads
Modified: 2019-07-04 09:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1722523
Environment:
Last Closed: 2019-07-04 09:01:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:50 UTC

Description David Eads 2019-06-20 14:47:28 UTC
+++ This bug was initially created as a clone of Bug #1722523 +++

There is a file called metrics.json, but it contains version informatino

Comment 2 Xingxing Xia 2019-06-21 07:36:51 UTC
Good catch. Thanks for erporting. Reproduced in 4.1.0-0.nightly-2019-06-20-015058 that does not yet include the PR.
$ oc adm must-gather
$ cd must-gather.local.5508871782420196078
$ vi -p `find . -name metrics.json` # metrics.json files for the namespaces/openshift-kube-apiserver and namespaces/openshift-apiserver pods are overridden to version info.

Comment 4 Xingxing Xia 2019-06-27 09:48:05 UTC
Verified with bug 1722523#c2 steps using oc v4.1.4-201906261555 in env of latest 4.1 payload 4.1.0-0.nightly-2019-06-27-030910

Comment 6 errata-xmlrpc 2019-07-04 09:01:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.