Bug 1722588 - xfce4-settings 4.13.6-1 is not rendering its gui properly, buttons hidden etc
Summary: xfce4-settings 4.13.6-1 is not rendering its gui properly, buttons hidden etc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-settings
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1722587 1725196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-20 17:07 UTC by Walter Francis
Modified: 2019-08-24 12:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-24 12:11:32 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of xfce4-display-settings (68.20 KB, image/png)
2019-06-20 17:07 UTC, Walter Francis
no flags Details

Description Walter Francis 2019-06-20 17:07:38 UTC
Created attachment 1582756 [details]
Screenshot of xfce4-display-settings

Description of problem:
I have several XFCE systems and I noticed that every one I update the xfce4-display settings has issues.  The most obvious one is that the GUI is missing all of the buttons, such as to pick the display resolution etc.  A secondary issue  is that it's also not defaulting to my previously picked resolution.  Both issues are resolved if I downgrade from 4.13.6-1 to 4.13.5-4

Version-Release number of selected component (if applicable):
xfce4-settings-4.13.6-1.fc30.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Upgrade F30 XFCE system
2. Try to launch xfce4-display-settings directly or via XFCE settings menus etc
3. Note that the GUI is corrupt

Secondary, and more annoying really
1. Set a display resolution of something bigger than it currently is
2. Log out, reboot
3. Log in, note that the resolution is back to some default (for me it keeps defaulting to 1024x768)

Both issues go away when downgrading to 4.13.5-4

Actual results:
Inline in steps

Expected results:
1:  xfce4-display-settings isn't busted ;)
2:  previously set resolution is honored

Additional info:
Some cats are actually allergic to humans.

Comment 1 Kevin Fenzi 2019-06-20 17:11:02 UTC
*** Bug 1722587 has been marked as a duplicate of this bug. ***

Comment 2 Mukundan Ragavan 2019-06-20 22:22:48 UTC
Thanks for the report.

The workaround for this at the moment is saving a display setting. 

Upstream already knows about this and this will be part of updates in the coming weeks.

Comment 3 Walter Francis 2019-06-20 22:32:01 UTC
I found the workaround of creating a display profile but that did not work at all for me.  I set my profile up the way I wanted, it created a new profile (blindly; you can't see anything you're doing), and it did not help at all.

The only workaround I know of is downgrading.

Comment 4 Mukundan Ragavan 2019-06-21 01:45:56 UTC
Let me try to duplicate this issue then.

Comment 5 Mukundan Ragavan 2019-06-23 14:00:04 UTC
Can you try this bugfix build and see if it fixes the issue?

https://koji.fedoraproject.org/koji/taskinfo?taskID=35758216

I am unable to reproduce this. So this fix is a shot in the dark.

Comment 6 Walter Francis 2019-06-23 15:19:17 UTC
(In reply to Mukundan Ragavan from comment #5)
> Can you try this bugfix build and see if it fixes the issue?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=35758216
> 
> I am unable to reproduce this. So this fix is a shot in the dark.

This build does fix the UI in the xfce-display-settings GUI so I think we can close this, although there is still an issue that it doesn't persist the settings.  So every time I login, it's back to 1024x768.  Not sure what to do there.  I also can't really create a new profile, if I do, it doesn't show in the list, but if I create another one of the same name it says it exists.  None the less I think this specific issue is resolved, but perhaps there are other packages that need some fix too.  Not even sure where to begin to figure out what those are.

As for reproduction, it might be only something seen in KVM, not sure, I've seen it on multiple systems but only in KVM.  I don't have F30 anywhere else just yet.

Comment 7 Kevin Fenzi 2019-06-28 21:35:38 UTC
*** Bug 1725196 has been marked as a duplicate of this bug. ***

Comment 8 Bernie Hoefer 2019-07-03 13:59:19 UTC
(In reply to Walter Francis from comment #6)
===
> (In reply to Mukundan Ragavan from comment #5)
> > Can you try this bugfix build and see if it fixes the issue?
> > 
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=35758216
> > 
> > I am unable to reproduce this. So this fix is a shot in the dark.
> 
> This build does fix the UI in the xfce-display-settings GUI so I think we
> can close this, although there is still an issue that it doesn't persist the
> settings.  So every time I login, it's back to 1024x768.
===

I've had this same problem and recently installed the fixed xfce4-settings-4.13.6-2.fc30.x86_64.  Not only did it correct the XFCE Display window's behavior, but it does remember the resolutions for my multiple-monitor configuration.

===
> As for reproduction, it might be only something seen in KVM, not sure, I've
> seen it on multiple systems but only in KVM.  I don't have F30 anywhere else
> just yet.
===

Could be.  My Fedora 30 is installed on a laptop using its built-in screen and 2 monitors connected through the docking station's DE-15 VGA and DisplayPort connectors.

Comment 9 Fedora Update System 2019-08-15 22:31:20 UTC
FEDORA-2019-8b21f399ee has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b21f399ee

Comment 10 Fedora Update System 2019-08-17 01:27:18 UTC
Thunar-1.8.9-1.fc30, exo-0.12.8-1.fc30, garcon-0.6.4-3.fc30, gigolo-0.5.0-2.fc30, libxfce4ui-4.14.1-1.fc30, libxfce4util-4.14.0-1.fc30, parole-1.0.4-1.fc30, ristretto-0.10.0-2.fc30, thunar-volman-0.9.5-1.fc30, tumbler-0.2.7-1.fc30, xfce4-appfinder-4.14.0-1.fc30, xfce4-battery-plugin-1.1.3-1.fc30, xfce4-datetime-plugin-0.8.0-1.fc30, xfce4-diskperf-plugin-2.6.2-1.fc30, xfce4-fsguard-plugin-1.1.1-1.fc30, xfce4-genmon-plugin-4.0.2-1.fc30, xfce4-mpc-plugin-0.5.2-1.fc30, xfce4-netload-plugin-1.3.2-1.fc30, xfce4-panel-4.14.0-1.fc30, xfce4-places-plugin-1.8.1-1.fc30, xfce4-power-manager-1.6.5-1.fc30, xfce4-pulseaudio-plugin-0.4.2-1.fc30, xfce4-screensaver-0.1.8-2.fc30, xfce4-session-4.14.0-1.fc30, xfce4-settings-4.14.0-1.fc30, xfce4-smartbookmark-plugin-0.5.1-1.fc30, xfce4-systemload-plugin-1.2.3-1.fc30, xfce4-time-out-plugin-1.0.3-1.fc30, xfce4-wavelan-plugin-0.6.1-1.fc30, xfce4-weather-plugin-0.10.0-1.fc30, xfconf-4.14.1-1.fc30, xfdashboard-0.7.5-4.fc30, xfdesktop-4.14.1-1.fc30, xfwm4-4.14.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b21f399ee

Comment 11 Walter Francis 2019-08-17 17:34:16 UTC
I had not tried the previous ones, but I did dnf update from testing today to XFCE 4.14 and it works without forcing xrandr again now.  I did have to set the display size once and after that it works.

Login manager still defaults to low res (1024?) but that's not a huge deal.

Comment 12 Fedora Update System 2019-08-23 01:26:56 UTC
Thunar-1.8.9-1.fc30, exo-0.12.8-1.fc30, garcon-0.6.4-3.fc30, gigolo-0.5.0-2.fc30, libxfce4ui-4.14.1-1.fc30, libxfce4util-4.14.0-1.fc30, parole-1.0.4-1.fc30, ristretto-0.10.0-2.fc30, thunar-volman-0.9.5-1.fc30, tumbler-0.2.7-1.fc30, xfce4-appfinder-4.14.0-1.fc30, xfce4-battery-plugin-1.1.3-1.fc30, xfce4-datetime-plugin-0.8.0-1.fc30, xfce4-diskperf-plugin-2.6.2-1.fc30, xfce4-fsguard-plugin-1.1.1-1.fc30, xfce4-genmon-plugin-4.0.2-1.fc30, xfce4-mpc-plugin-0.5.2-1.fc30, xfce4-netload-plugin-1.3.2-1.fc30, xfce4-panel-4.14.0-1.fc30, xfce4-places-plugin-1.8.1-1.fc30, xfce4-power-manager-1.6.5-1.fc30, xfce4-pulseaudio-plugin-0.4.2-1.fc30, xfce4-screensaver-0.1.8-2.fc30, xfce4-session-4.14.0-1.fc30, xfce4-settings-4.14.0-1.fc30, xfce4-smartbookmark-plugin-0.5.1-1.fc30, xfce4-systemload-plugin-1.2.3-1.fc30, xfce4-time-out-plugin-1.0.3-1.fc30, xfce4-wavelan-plugin-0.6.1-1.fc30, xfce4-weather-plugin-0.10.0-1.fc30, xfconf-4.14.1-1.fc30, xfdashboard-0.7.5-4.fc30, xfdesktop-4.14.1-1.fc30, xfwm4-4.14.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Bernie Hoefer 2019-08-23 13:45:51 UTC
(In reply to Fedora Update System from comment #9)

> FEDORA-2019-8b21f399ee has been submitted as an update to Fedora 30.
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-8b21f399ee

I just tested the above build, updating from the fix that Mukundan Ragavan provided in comment #5.  (That fix worked great.)


# rpm -q xfce4-settings
xfce4-settings-4.13.8-1.fc30.x86_64

# dnf config-manager --set-enabled updates-testing

# dnf install xfce4-settings
Last metadata expiration check: 0:00:30 ago on 2019-08-23T08:26:56 EST.
Dependencies resolved.
================================================================================
 Package               Architecture  Version               Repository      Size
================================================================================
Installing:
 xfce4-settings        x86_64        4.14.0-1.fc30         updates        802 k
Transaction Summary
================================================================================
Total download size: 802 k
Installed size: 4.1 M
Is this ok [y/N]: y
{...}
Installed:
  xfce4-settings-4.14.0-1.fc30.x86_64                                           
Complete!


Even though I rebooted  my machine (per the "Reboot Required" note at the top of that bodhi web page), when I clicked on the Display app from the Xfce menu, nothing appears.  Removing it and re-installing the older version made it work; no reboot required.


# rpm -e xfce4-settings --nodeps

# rpm -ivh /tmp/xfce4-settings-4.13.8-1.fc30.x86_64.rpm 
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Updating / installing...
   1:xfce4-settings-4.13.8-1.fc30     ################################# [100%]

Comment 14 Bernie Hoefer 2019-08-23 13:59:01 UTC
Doh.  I just noticed in my last comment that xfce4-settings was installed from the updates repository, not the updates-testing one.  I did not see that the packages listed in comment #12 have "been pushed to the Fedora 30 stable repository".

So, I performed a "dnf -y update", which updated 49 packages, including most of the 34 listed in comment #12.  This time, clicking on the Display app from the menu worked fine; I did not have to reboot.

Comment 15 Mukundan Ragavan 2019-08-24 12:11:32 UTC
Excellent then. I will close this bug. Please reopen if needed.


Note You need to log in before you can comment on or make changes to this bug.